Defect #23912

No validation error when date value is invalid in time entries filter

Added by Pavel Potcheptsov about 1 year ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Time tracking
Target version:3.4.0
Resolution:Fixed Affected version:3.3.0

Description

For example if I go to http://example.com/projects/my_project/time_entries and
choose date between real dates by using datepicker then it shows correct data.
But once I enter or change any date to fake one, like from 2016-09-01 to 2016-09-010 no matter for start or end date's field then it shows total time from the very beginning of the project.

Expected behavior: wrong date message.

Screen Shot 2017-05-27 at 17.41.20.png (70.9 KB) Marius BALTEANU, 2017-05-27 16:41

Associated revisions

Revision 16635
Added by Jean-Philippe Lang 6 months ago

DOn't show time entries when query is invalid (#23912).

History

#1 Updated by Toshi MARUYAMA about 1 year ago

  • Description updated (diff)

#2 Updated by Toshi MARUYAMA about 1 year ago

  • Description updated (diff)

#3 Updated by Marius BALTEANU 6 months ago

I cannot reproduce on the current trunk (r16578). If I use the following query:

utf8=✓&set_filter=1&sort=spent_on:desc&f[]=spent_on&op[spent_on]==&v[spent_on][]=2016-09-010&f[]=&c[]=spent_on&c[]=user&c[]=activity&c[]=issue&c[]=comments&c[]=hours&group_by=&t[]=hours&t[]=

I receive the error "Date is invalid" (screenshot attached).

#4 Updated by Marius BALTEANU 6 months ago

Considering that the issue reproduces on Redmine 3.3.3, but not in the current trunk, I think that we can mark this defect as fixed in 3.4.0.

#5 Updated by Go MAEDA 6 months ago

  • Subject changed from Validate date input to No validation error when date value is invalid in time entries filter
  • Status changed from New to Resolved
  • Target version set to 3.4.0

It seems to be fixed in r15649. "Date is invalid" error is displayed as expected.

#6 Updated by Jean-Philippe Lang 6 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Marius BALTEANU wrote:

I receive the error "Date is invalid" (screenshot attached).

Indeed, but all the time entries are displayed below this message. It's fixed in r16635 (no results displayed when query is invalid)

#7 Updated by Pavel Potcheptsov 5 months ago

Thanks!

Also available in: Atom PDF