Feature #24927

Render high resolution Gravatars and Thumbnails

Added by Jan from Planio www.plan.io about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI
Target version:3.4.0
Resolution:Fixed

Description

In addition to #24922, this patch implements hi-res support for Gravatars and Thumbnails using the srcset attribute. Only a DPR of 2x is supported currently.

Here, the patch will actually use separate URLs for 1x and 2x images, so that browsers supporting srcset will only load the appropriate image and will not need to scale on the client.

0002-Hires-2x-DPR-image-support-for-Thumbnails.patch Magnifier (897 Bytes) Jan from Planio www.plan.io, 2017-01-26 12:35

0001-Hires-2x-DPR-image-support-for-Gravatars.patch Magnifier (914 Bytes) Jan from Planio www.plan.io, 2017-01-26 13:36

24927-thumbnail-problem-in-firefox.png (73 KB) Go MAEDA, 2017-01-28 12:21

0003-Whitespace-only-reorg-of-ApplicationHelper-thumbnail.patch Magnifier (1.43 KB) Jan from Planio www.plan.io, 2017-01-28 19:19

0004-set-thumbnail-width-on-image-tag-to-avoid-too-wide-w.patch Magnifier (958 Bytes) Jan from Planio www.plan.io, 2017-01-28 19:19

24927-effect-gravatar.png (79.5 KB) Go MAEDA, 2017-01-29 03:43


Related issues

Related to Redmine - Feature #24922: Support high resolution images in formatted content Closed
Related to Redmine - Feature #11757: Add support for HDPI screens (retina) New
Blocked by Redmine - Defect #24935: Gravatar icons in activity view are broken on r15858 and ... Closed

Associated revisions

Revision 16313
Added by Jean-Philippe Lang about 1 month ago

Hires (2x DPR) image support for Gravatars (#24927).

Patch by Jan Schulz-Hofen.

Revision 16314
Added by Jean-Philippe Lang about 1 month ago

Hires (2x DPR) image support for Thumbnails (#24927).

Patch by Jan Schulz-Hofen.

Revision 16315
Added by Jean-Philippe Lang about 1 month ago

Whitespace-only reorg of ApplicationHelper#thumbnail_tag (#24927).

Patch by Jan Schulz-Hofen.

Revision 16316
Added by Jean-Philippe Lang about 1 month ago

Set thumbnail width on image tag to avoid too wide white boxes on Firefox (#24927).

Patch by Jan Schulz-Hofen.

History

#1 Updated by Jan from Planio www.plan.io about 1 month ago

  • Related to Feature #24922: Support high resolution images in formatted content added

#2 Updated by Jan from Planio www.plan.io about 1 month ago

  • File deleted (0001-Hires-2x-DPR-image-support-for-Gravatars.patch)

#4 Updated by Go MAEDA about 1 month ago

  • Related to Feature #11757: Add support for HDPI screens (retina) added

#5 Updated by Go MAEDA about 1 month ago

  • Blocked by Defect #24935: Gravatar icons in activity view are broken on r15858 and later added

#6 Updated by Go MAEDA about 1 month ago

Thanks for the patch. Gravatar icons and thumbnails for HDPI display is beautiful.
But I see strange blank area in Firefox. Could you inspect it?

#8 Updated by Jan from Planio www.plan.io about 1 month ago

Thanks for pointing this out. I'm adding two more patches which fix this problem. To me it looks like a bug in Firefox, though...

#9 Updated by Go MAEDA about 1 month ago

Jan from Planio www.plan.io wrote:

Thanks for pointing this out. I'm adding two more patches which fix this problem.

Thanks, I confirmed that the problem has been fixed.

#10 Updated by Go MAEDA about 1 month ago

With these patches, we can see sharp Gravatar icons and thumbnails on High DPI monitors.
High DPI monitors are becoming common these days, so I think that this feature should be included in 3.4.0.

#11 Updated by Jean-Philippe Lang about 1 month ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Committed, thanks.

Also available in: Atom PDF