Defect #30718

Translation missing for filter by project status

Added by Vladislav Yashin 9 months ago. Updated 8 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Issues filter
Target version:4.0.2
Resolution:Fixed Affected version:4.0.1

Description

Redmine version: 4.0.1.stable
Ruby version: 2.6.0

Снимок экрана 2019-01-30 в 11.44.26.png (30.7 KB) Vladislav Yashin, 2019-01-30 08:44

Screenshot_2019-02-13 Issues.png - screenshot about issue (6.81 KB) Lszl Frng, 2019-02-13 17:01

0001-Fix-30718.patch Magnifier (1.42 KB) Marius BALTEANU, 2019-02-14 22:52

query_test.rb.patch Magnifier (479 Bytes) Pavel Rosický, 2019-02-15 15:06


Related issues

Related to Redmine - Feature #20081: Filter issues and time entries by project status Closed

Associated revisions

Revision 17868
Added by Go MAEDA 8 months ago

Ensure that the current language is 'en' in the test (#30718).

Patch by Pavel Rosický.

Revision 17869
Added by Go MAEDA 8 months ago

Translation missing error in "Project's Status" filter options (#30718).

Patch by Marius BALTEANU.

Revision 17871
Added by Go MAEDA 8 months ago

Merged r17868 from trunk to 4.0-stable (#30718).

Revision 17872
Added by Go MAEDA 8 months ago

Merged r17869 from trunk to 4.0-stable (#30718).

History

#1 Updated by Bernhard Rohloff 9 months ago

I can reproduce this issue on my upgraded production instance. Surprisingly it doesn't occur in my development setup.

#2 Updated by Lszl Frng 8 months ago

The problem is also present in version 4.0.0.stable

Environment:
Redmine version 4.0.0.stable
Ruby version 2.5.1-p57 (2018-03-29) [x86_64-linux-gnu]
Rails version 5.2.2
Environment production
Database adapter Mysql2
Mailer queue ActiveJob::QueueAdapters::AsyncAdapter
Mailer delivery smtp
SCM:
Subversion 1.9.7
Git 2.17.1
Filesystem
Redmine plugins:
redmine_agile 1.4.7
redmine_issue_dynamic_edit 0.6.5
redmine_lightbox2 0.5.0

#3 Updated by Marius BALTEANU 8 months ago

  • Assignee set to Marius BALTEANU

#4 Updated by Pavel Rosický 8 months ago

I can confirm the problem.

status translations are evaluated only once during start of the server, see
https://github.com/redmine/redmine/blob/4e9886f9b5d4df10cd76d67312c06b8af5a17903/app/models/project.rb#L28

as a result it'll always be in english or translation missing (in combination with some 3rd party plugins).

QueryTest#test_project_statuses_values_should_return_only_active_and_closed_statuses should also be fixed because the test always expects english strings even if the current locale is different

Expected: [["active", "1"], ["closed", "5"]]
  Actual: [["actif", "1"], ["fermé", "5"]]

#5 Updated by Marius BALTEANU 8 months ago

  • Related to Feature #20081: Filter issues and time entries by project status added

#6 Updated by Marius BALTEANU 8 months ago

  • File fix_for_30718.patch added

Could you test, please, the attached patch and tell me if it fixes the problem?

#7 Updated by Marius BALTEANU 8 months ago

  • File deleted (fix_for_30718.patch)

#8 Updated by Marius BALTEANU 8 months ago

#9 Updated by Pavel Rosický 8 months ago

works fine, thanks

#10 Updated by Marius BALTEANU 8 months ago

  • Target version set to 4.0.2

#11 Updated by Marius BALTEANU 8 months ago

  • Assignee deleted (Marius BALTEANU)

Patches to commit:
1. 0001-Fix-30718.patch
2. query_test.rb.patch

#12 Updated by Go MAEDA 8 months ago

  • Status changed from New to Resolved
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed. Thank you all for reporting, investigating, and fixing this issue.

#13 Updated by Go MAEDA 8 months ago

  • Status changed from Resolved to Closed

Merged to 4.0-stable branch.

Also available in: Atom PDF