Defect #31438

Incorrect position of the "Associated revisions" block when comments are displayed in reverse chronological order

Added by Mathias Buder 5 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:UI
Target version:4.0.4
Resolution:Fixed Affected version:4.0.3

Description

Hi all,

I noticed that the associated revisions block is not places next to the comments section as it used to be. This happens when a user selects to display comments - In reverse chronological order option in /my/account. If it is set up to be displayed in chronological order everything looks just fine. I've attached a screenshot with shows the issue (this is the Purplemine theme here but it happen with the original one too).

mrliptontea from the Purplemine project found the root cause for this and wrote the following:

Aha! I found the cause - this happens when a user selects Display comments - In reverse chronological order option in /my/account.
The same layout issue then happens with the default theme. This is because with reversed order the contextual menu is also displayed above the comment history, as defined in the template.

Sorry but I'm afraid I can't fix this.

He marked the possible issue inside the redmine source code here.

Wrong_location_assisiated_revisions.png (36.5 KB) Mathias Buder, 2019-05-24 09:45

2019-05-26 14_59_33-Window.png (19.3 KB) Mathias Buder, 2019-05-26 15:00

fix-31438.diff Magnifier (667 Bytes) Go MAEDA, 2019-05-27 05:15

31438-before@2x.png (25.6 KB) Go MAEDA, 2019-05-27 05:20

31438-after@2x.png (32.9 KB) Go MAEDA, 2019-05-27 05:20


Related issues

Related to Redmine - Feature #3058: Show issue history using tabs Closed 2009-03-26
Related to Redmine - Feature #23518: Move action links and edit form above the history when di... Closed

Associated revisions

Revision 18229
Added by Go MAEDA 5 months ago

Fix incorrect position of the "Associated revisions" block when comments are displayed in reverse chronological order (#31438).

Patch by Go MAEDA.

Revision 18235
Added by Go MAEDA 5 months ago

Merged r18229 from trunk to 4.0-stable (#31438).

History

#1 Updated by Go MAEDA 5 months ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Since the problem occurs only in the third-party theme, there is nothing we can do.

I hope the theme developer suggests how to update the Redmine's code to fix their issue.

#2 Updated by Mathias Buder 5 months ago

Hi,

thanks for the quick replay.

As I've wrote in the description is happens also with the default Redmine theme. See attached screenshot.

Mathias Buder wrote:

Hi all,

I noticed that the associated revisions block is not places next to the comments section as it used to be. This happens when a user selects to display comments - In reverse chronological order option in /my/account. If it is set up to be displayed in chronological order everything looks just fine. I've attached a screenshot with shows the issue (this is the Purplemine theme here but it happen with the original one too).

#3 Updated by Go MAEDA 5 months ago

  • Resolution deleted (Invalid)

I think it will be fixed if #3058 is merged to the trunk.

#4 Updated by Go MAEDA 5 months ago

#5 Updated by Go MAEDA 5 months ago

I think the attached patch fixes the issue.

[Before]

[After]

#6 Updated by Go MAEDA 5 months ago

  • Related to Feature #23518: Move action links and edit form above the history when displaying comments in reverse order added

#7 Updated by Go MAEDA 5 months ago

  • Target version changed from Candidate for next minor release to 4.0.4

#8 Updated by Go MAEDA 5 months ago

  • Subject changed from Associated revisions block not places next to history to Incorrect position of the "Associated revisions" block when comments are displayed in reverse chronological order
  • Status changed from Confirmed to Resolved
  • Assignee set to Go MAEDA

Committed the fix. Thank you for reporting this issue.

#9 Updated by Go MAEDA 5 months ago

  • Status changed from Resolved to Closed
  • Resolution set to Fixed

Also available in: Atom PDF