Feature #5224

Add custom field type that allows multiple values

Added by Eric Hollering over 7 years ago. Updated almost 6 years ago.

Status:ClosedStart date:2010-03-30
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Duplicate

Description

It would be very handy to have some kind of multi-value custom field control, such as a checked list.

The specific application I have in my mind, which will help me illustrate this, is to record what technologies pertain to a particular issue.

I might have the possible values enumerated as "MS SQL", "MySql", "C#", and "Ruby". Then if I have an issue that requires some work done with MS SQL, my DBA (who currently lacks the tools and/or training to work in C# or Ruby) could quickly filter the open issues and see what she could contribute.

As it stands now I'd have to either define a text box and rely on nobody typing "MSSQL" instead of "MS SQL" when searching, or I'd have to create a custom field for each possible technology (the actual list could be way longer than 4 items).

The ideal interface would look like the section for adding Watchers (which is awesome by the way).


Related issues

Duplicates Redmine - Feature #1189: Multiselect custom fields Closed 2008-05-06
Duplicates Redmine - Feature #5176: Multiple select list in custom fields Closed 2010-03-24

History

#1 Updated by Enderson Maia over 7 years ago

Maybe a duplication of #5176.

#2 Updated by Eric Hollering over 7 years ago

Definitely a duplication -- I did search though, I promise. ;)

However, if possible, I still want to promote the same interface that is used for Watchers, Related Issues, etc. It is just so clean and elegant that way!

I'll make my suggestion on #5176.

#3 Updated by Holger Just over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed for being a duplicate of #1189.

#4 Updated by Ryan Cross almost 7 years ago

  • Status changed from Closed to Reopened

I think this is slightly different than multi-select lists.

As an example, I would like to have a multi-value field for website projects where I can put in urls. Most projects only have 1 or 2 urls, but some projects have 4,5,6,etc. I could do this with a text area, but i would like to have a structured piece of data to work with over time.

#5 Updated by Toshi MARUYAMA over 6 years ago

  • Category set to Custom fields

#6 Updated by Jean-Philippe Lang almost 6 years ago

  • Status changed from Reopened to Closed

Feature added in r8721.
When creating a list, user or version custom field, you can now check the "Multiple values" checkbox to make the custom fields accept multiple values.

Also available in: Atom PDF