Feature #7402

REST API - Enumerations

Added by Markus May over 6 years ago. Updated over 3 years ago.

Status:NewStart date:2011-01-21
Priority:HighDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:Candidate for next major release
Resolution:

Description

it would be great to have access to all enumerations via the REST API. Right now, at least from what I understood, I would have to get all issues and then hope that all Statuses/Resolutions are in there.


Related issues

Related to Redmine - Feature #7180: List of statuses in REST API Closed 2010-12-27
Related to Redmine - Defect #7819: REST API Populating issue field enumerations + Issue list... New 2011-03-09
Related to Redmine - Feature #9835: REST API - List priorities Closed
Duplicated by Redmine - Defect #8596: Make possible to obtain issue_priorities and issue_status... Closed 2011-06-13
Duplicated by Redmine - Feature #11169: Please add API to get priority list Closed

History

#1 Updated by Jack T over 6 years ago

This would be really useful.

#2 Updated by RedminePro Yang over 6 years ago

+1

#3 Updated by Alex Last over 6 years ago

See #7180

#4 Updated by Bevan Rudge about 6 years ago

This is duplicate of one or some of the following;

#5 Updated by Bevan Rudge about 6 years ago

I meant #7819, not #7402.

#6 Updated by Etienne Massip almost 6 years ago

  • Priority changed from Normal to High
  • Target version set to Candidate for next major release

As #7180, REST-blocking for instances which don't set a default Priority, etc.

#7 Updated by The Anchialos over 5 years ago

+1
We need this feature for RedmineNB (NetBeans Plugin for integration with Redmine).

#8 Updated by Alex V. over 5 years ago

+1
Getting Enumerations is crucial

#9 Updated by Tim Klein over 5 years ago

+1

#10 Updated by Robert Zieschang almost 5 years ago

+1

What's the status?
Candidate for Majorrelease 3?

#11 Updated by Peter Modica over 4 years ago

+1

#12 Updated by Marco Descher over 3 years ago

+1

Also available in: Atom PDF