Defect #7577

"Send account information to the user" only works when password is set

Added by R W about 6 years ago. Updated 23 days ago.

Status:ClosedStart date:2011-02-08
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Administration
Target version:3.4.0
Resolution:Fixed Affected version:

Description

MySQL: 5.1.49
Ruby: 1.8.7
Rails: 2.3.5
Redmine: 1.1.1.stable.4802 (MySQL)

Account information is not sent to users when the box next to "Send account information to the user" is checked on

http://redmineurl/users/4/edit
http://redmineurl/users/new


Related issues

Related to Redmine - Patch #25249: Change translation for label_send_information Closed

Associated revisions

Revision 16453
Added by Jean-Philippe Lang 23 days ago

Send email even if password is not changed (#7577).

History

#1 Updated by Jean-Philippe Lang about 6 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

Can not reproduce with either 1.1-stable or trunk.
Make sure your email delivery is properly setup.

#2 Updated by Matt Connolly about 6 years ago

  • Status changed from Closed to Reopened

I can reproduce this issue. The problem I see is specific to editing a user.

If you edit a user and have the "Send account information to the user" option checked, the details are only sent to the user if a new password has been explicitly set. ie: If you change their name or email, nothing will be sent.

Is this by design? If so, it's confusing and perhaps the label for the checkbox could be "Send new password to the user" which infers that it will not do anything unless a new password has been entered.

#3 Updated by Etienne Massip about 6 years ago

  • Target version set to Candidate for next minor release

Condition at source:trunk/app/controllers/users_controller.rb#L160 is :

@user.active? && params[:send_information] && !params[:user][:password].blank? && @user.auth_source_id.nil?

So you're right, a new password needs to be entered which is a bit confusing.
This checkbox is used to send new account information to the user at creation too.

#4 Updated by Steve Moyer about 5 years ago

I ran into a variant of this bug that I thought was worth mentioning. I'm using LDAP authentication with my Redmine instance and therefore there is no password to change. But when I create a user account in Redmine, I really would like to send an e-mail with the details. So I guess I'm also voting for the idea that any account creation or account change (or even clicking the save button again without changes) be allowed to create the e-mail.

#5 Updated by Oleg Kozlyuk over 4 years ago

+1. Sending info to LDAP users would be helful.

#6 Updated by Miodrag Milic over 4 years ago

+1 for LDAP users

Actually, this should be a button visible for admins only.

#7 Updated by Daniel Felix over 4 years ago

Etienne Massip wrote:

Condition at source:trunk/app/controllers/users_controller.rb#L160 is :
[...]

So you're right, a new password needs to be entered which is a bit confusing.
This checkbox is used to send new account information to the user at creation too.

Any news on this Etienne? :-)
Maybe this could be fixed in the next minor release?

#8 Updated by Jean-Philippe Lang over 4 years ago

The existing email notification is used to send the password, that's why it's only sent when the password is set. If we want to be able to send an email in any case, it would be better to define different templates for when:
  1. the account was created
  2. the account was updated without password change
  3. the password was changed

In 2., what should the email look like?

#9 Updated by Etienne Massip over 4 years ago

Suggestion:

    • object: Your account has been created
    • body: every field name and value visible in the Information fieldset of the user account screen and password if internal auth
    • object: Summary of your account
    • body: every field name and value visible in the Information fieldset of the user account screen
    • object: Your authentication information has been updated
    • body: password and every field name and value visible in the Information fieldset of the user account screen

Edited x times

#10 Updated by Daniel Felix about 4 years ago

  • Tracker changed from Defect to Feature

This is more likely a feature request then a defect.

#11 Updated by Go MAEDA about 1 month ago

  • Related to Patch #25249: Change translation for label_send_information added

#12 Updated by Jean-Philippe Lang about 1 month ago

  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next minor release to 3.4.0
  • Resolution deleted (Cant reproduce)

#13 Updated by Jean-Philippe Lang 23 days ago

  • Tracker changed from Feature to Defect
  • Subject changed from "Send account information to the user" is broken to "Send account information to the user" only works when password is set
  • Status changed from Reopened to Closed
  • Resolution set to Fixed

Change done in r16453. An email with username and login URL will now be sent when the password is not changed.

Also available in: Atom PDF