redMine 500 error while saving new issue

Added by gaurabmani shrestha about 11 years ago

When i try to add a new issue in Redmine i get the following error.
*Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your redMine administrator for assistance.*

In other section i can add without any issue but it occurs only in the Issue section.
How can i get rid of the issue.

Replies (6)

RE: redMine 500 error while saving new issue - Added by Felix Schäfer about 11 years ago

Please post the trace of the error, you will find that in the log/production.log.

RE: redMine 500 error while saving new issue - Added by gaurabmani shrestha about 11 years ago

Below is the error from the log file.
*<html>
<head>
<style>
body {
font-family: Verdana, sans-serif;
font-size: 0.8em;
color:#484848;
}
h1, h2, h3 { font-family: "Trebuchet MS", Verdana, sans-serif; margin: 0p=
x; }
h1 { font-size: 1.2em; }
h2, h3 { font-size: 1.1em; }
a, a:link, a:visited { color: #2A5685;}
a:hover, a:active { color: #c61a1a; }
a.wiki-anchor { display: none; }
hr {
width: 100%;
height: 1px;
background: #ccc;
border: 0;
}
.footer {
font-size: 0.8em;
font-style: italic;
}
</style>
</head>
<body>
Issue #14 has been reported by Gaurav Shrestha.
<hr />
<h1><a href=3D"http://localhost:3000/redmine/issues/14">Bug #14: testing<=
/a></h1>

<ul>
<li>Author: Gaurav Shrestha</li>
<li>Status: New</li>
<li>Priority: Normal</li>
<li>Assigned to: </li>
<li>Category: </li>
<li>Target version: </li>

</ul>

<hr />
<span class=3D"footer"><p>You have received this notification because you=
have either subscribed to it, or are involved in it.<br />To change your=
notification preferences, please click here: <a class=3D"external" href=3D=
"http://hostname/my/account">http://hostname/my/account&lt;/a&gt;&lt;/p&gt;&lt;/span>
</body>
</html>

--mimepart_4ccd45f565fd_445415694615fb34139d--
SQL (2.3ms) ROLLBACK

Timeout::Error (execution expired):
/usr/lib/ruby/1.8/timeout.rb:60:in `open'
/usr/lib/ruby/1.8/net/smtp.rb:551:in `do_start'
/usr/lib/ruby/1.8/net/smtp.rb:551:in `do_start'
/usr/lib/ruby/1.8/net/smtp.rb:525:in `start'
app/models/mailer.rb:292:in `deliver!'
app/models/issue_observer.rb:20:in `after_create'
/usr/lib/ruby/1.8/observer.rb:185:in `notify_observers'
/usr/lib/ruby/1.8/observer.rb:184:in `each'
/usr/lib/ruby/1.8/observer.rb:184:in `notify_observers'
app/controllers/issues_controller.rb:143:in `create'

Rendering /home/strag/rails_apps/redmine/public/500.html (500 Internal Server Error) *

RE: redMine 500 error while saving new issue - Added by Felix Schäfer about 11 years ago

Please use the < pre> tags (there's an extra space in there to avoid it getting triggered here, see the text formatting help for more info) when pasting logs or configuration files, that makes them more readable.

From your error log, it seems the smtp call times out, i.e. I guess your email config is faulty.

RE: redMine 500 error while saving new issue - Added by gaurabmani shrestha about 11 years ago

Thanks Felix for pointing out the issue. I removed the mail configuration and it is working fine now.

RE: redMine 500 error while saving new issue - Added by axe axe almost 11 years ago

I have same problem. My log/production.log error is

Processing IssuesController#new (for 202.170.94.238 at 2011-01-10 09:18:42) [GET]
Parameters: {"project_id"=>"test123", "action"=>"new", "controller"=>"issues"}
Rendering template within layouts/base
Rendering issues/new

ActionView::TemplateError (undefined method `-' for nil:NilClass) on line #10 of app/views/issues/_attributes.rhtml:
7: <p><label><%= l(:field_status) ></label> <= @issue.status.name ></p>
8: <
end >
9:
10: <p><
= f.select :priority_id, (@priorities.collect {|p| [p.name, p.id]}), {:required => true}, :disabled => ? ></p>
11: <p><
= f.select :assigned_to_id, (@issue.assignable_users.collect {|m| [m.name, m.id]}), :include_blank => true ></p>
12: <
unless @project.issue_categories.empty? >
13: <p><
= f.select :category_id, (@project.issue_categories.collect {|c| [c.name, c.id]}), :include_blank => true %>

app/views/issues/_attributes.rhtml:10:in `_run_rhtml_app47views47issues47_attributes46rhtml_locals_attributes_object'
app/views/issues/_attributes.rhtml:1:in `_run_rhtml_app47views47issues47_attributes46rhtml_locals_attributes_object'
app/views/issues/_form.rhtml:25:in `_run_rhtml_app47views47issues47_form46rhtml_locals_f_form_object'
app/views/issues/new.rhtml:7:in `_run_rhtml_app47views47issues47new46rhtml'
app/helpers/application_helper.rb:702:in `labelled_tabular_form_for'
app/views/issues/new.rhtml:3:in `_run_rhtml_app47views47issues47new46rhtml'
app/controllers/issues_controller.rb:122
app/controllers/issues_controller.rb:121:in `new'

Rendering /usr/home/redmine/public/500.html (500 Internal Server Error)

On redmine 1.0.5 stable version. I have recently upgrade redmine 0.9.0 to 1.0.5. New issue botton cant working pls help me guys?

RE: redMine 500 error while saving new issue - Added by Felix Schäfer almost 11 years ago

Davaasukh Dendev wrote:

I have same problem. My log/production.log error is

You don't have the same problem, you have the same symptom, and the actual problem you seem to have has been discussed numerous times on this forum. Please make sure to take the time and look for a thread relating to the problem you have instead of hijacking a seemingly random thread.

On redmine 1.0.5 stable version. I have recently upgrade redmine 0.9.0 to 1.0.5. New issue botton cant working pls help me guys?

Make sure the upgrade procedure went through correctly, especially the database migration. Please open a new thread in the help forum if you need further assistance.

(1-6/6)