How to configure CVS access?

Added by Thomas Wheeler over 11 years ago

I posted the following a couple weeks ago and got no response. This forum seems pretty redmine an active project? If not I will look elsewhere for my needs.


Hi all,

I'm trying to get Redmine to talk to my CVS server. Redmine is running on an XP box; CVS is on a Linux machine. When I set the CVSROOT and module name for the project it comes back pretty much immediately... I'm not sure what it supposed to happen afterwards, but the Redmine documentation says it should go off and collect information from your repository and that this is likely to take some time. I don't think it's doing that, but I can't find any error messages that tell me what's going on. So, a couple of questions:

1. How do I verify Redmine is connected to my CVS repository? Should I be able to browse the CVS repository (where)?
2. How do I turn on debug logging? I've edited both config/environment.rb and config/environments/production.rb to insert "log.log_level = :debug" and don't see anything in log/production.log.

A bit more info:

- cvs is in the path and works; I can set CVSROOT from the commandline and successfully execute a "cvs rlog".

- I'm running Ruby 1.8.6 (i386-mingw32), redmine-0.8.7, Rails 2.1.2.

Any other advice and suggestions are welcome....


Replies (8)

RE: How to configure CVS access? - Added by Jeffrey Jones over 11 years ago

Use the command line to run the rake task to fetch changesets (rake redmine:fetch_changesets) after you have setup your repository in the web interface. That should give you more of a clue as to if / why it is failing

RedMine is an actively developed project however the number of users in the forum is not that high; also people won't reply if they don't know the answer and I doubt there are that many CVS users compared to SVN etc.

The developers don't really use the forum. If you think there is a problem then raise an issue on the bugtracker.

RE: How to configure CVS access? - Added by Thomas Wheeler over 11 years ago

Thanks Jeffrey. Here's the output when I run rake per the above:

  • Invoke redmine:fetch_changesets (first_time)
  • Invoke environment (first_time)
  • Execute environment
  • Execute redmine:fetch_changesets
    cvs rlog: Logging demo
    cvs rlog: Logging demo/.settings
    cvs rlog: Logging demo/artifacts
    cvs [rlog aborted]: received broken pipe signal
    rake aborted!
    Errno::EBADF: Bad file descriptor - C:/dev/redmine-0.8.7/log/production.log: SELECT * FROM
    `changesets` WHERE (`changesets`.repository_id = 5 AND (`changesets`.`committer` = 'joe' AND `changesets`.`committed_on` BETWEEN '2009-08-01 04:31:07' AND '2009-08-01 04:31:27
    ' AND `changesets`.`comments` = 'removed extra page, aligned text')) ORDER BY changesets.c
    ommitted_on DESC, DESC LIMIT 1

Any ideas on where I can go from here?


RE: How to configure CVS access? - Added by Jeffrey Jones over 11 years ago

In short, RedMine cannot access the CVS repoistory. Have you quadruple checked that the location you entered in RedMine is correct?

RE: How to configure CVS access? - Added by Thomas Wheeler over 11 years ago


After double-checking (again) that CVSROOT was set correctly, I starting poking around a bit and shortly came to the conclusion that the problem had something to do with logging.

After some more rooting around, I figured out the problem. I don't know if this is a Windows-specific thing or a general Redmine thing, but in config/environments/production.rb there was no logger being created, just a commented-out line. This made me suspicious; I added

and the rake command completed successfully. I then started Redmine and am able to see the revision history. Yay! Now I can start evaluating Redmine in earnest.


RE: How to configure CVS access? - Added by Jeffrey Jones over 11 years ago

Gah, yes of course. I misread the Broken File Descriptor as referring to the CVS files, not the logger.

Sorry about that; glad it is working.

RE: How to configure CVS access? - Added by David Roncancio about 11 years ago

I have this same problem on a Centos 5.4 installation trying to connect to another Linux Box with the repository i found that the CVS client version being used doesnt support 'extssh' the following was the error "Unknown method (`extssh') " when using
rake redmine:fetch_changesets, i changed the conection from extssh to ext and retried the rake redmine:fetch_changesets and it worked and did the rlog however it asked for password but on the redmine itself it keeps showing the error_scm_not_found exception when trying to explore the repository

Any thoughts on this would be really appreciated

pd. Sorry bout my english

RE: How to configure CVS access? - Added by Thomas Wheeler about 11 years ago

Can you use pserver instead of ext? Maybe exploring the repository fails because it doesn't have the password.

The format should be something like:


You can try this on the command line first:

export CVSROOT=:pserver:username:password@my-cvs-host:/usr/local/cvsroot
cvs rlog my-project


RE: How to configure CVS access? - Added by krjuk OFF over 5 years ago

I have worked cvs on linux with
cvs -d :ext:user@host:/opt/ checkout module

on Server i have
Linux Cent OS Linux release 7.1.1503
Concurrent Versions System (CVS) 1.11.23 (client/server)

Red-mine version 3.1.0.stable
CVS version 1.12.13

But when i try to insert in remdine repository
CVSROOT* :ext:username@host_ip:/opt/cvsroot

I have error: The entry or revision was not found in the repository.