Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0)

Added by John Bulcher almost 10 years ago

I'm installing redmine on a bluehost server, and thanks to scripts like this one, most of everything is covered (except the RAILS_ENV=production rake config/initializers/session_store.rb step). However, when I try to run redmine, it claims that it can't fine hoe, even though it is installed. I was able to figure out what was wrong thanks to this site and a comment in the gem manager of my cpanel: it isn't picking up locally installed gems. Cpanel claims the solution is to add $:.push("/home4/gametisi/ruby/gems") to my script, but I don't know where to add it, or even if it is the right syntax. Can anyone help?

The specific error message I'm getting is:

(in /home4/gametisi/rails_apps/redmine)
rake aborted!
Could not find RubyGem hoe (>= 1.3.0)

Replies (8)

RE: Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0) - Added by John Bulcher almost 10 years ago

Whoops, forgot a few hyperlinks!

I meant to say "and thanks to scripts like this one"

and again "I was able to figure out what was wrong thanks to this site"

RE: Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0) - Added by John Bulcher almost 10 years ago

I managed to get it working by adding ENV['GEM_PATH'] ||= '(my path to ruby gems as found with the command gem environment)' before executing rake commands.

I was able to start the server and access the application locally using lynks (my setup put it on port 12009, not port 80), and in order to open up the port to the outside world, I needed to add dedicated IP to my server setup. I'm waiting for the DNS to propagate, at which point I am told I will be able to access the app.

RE: Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0) - Added by Radek Simcik over 9 years ago

hi John

I still cannot make it work:-) Where and how did you run ENV['GEM_PATH'] ?

Which directory did you use?

- INSTALLATION DIRECTORY: /home5/onalllev/ruby/gems
- RUBY EXECUTABLE: /usr/bin/ruby
- EXECUTABLE DIRECTORY: /home5/onalllev/ruby/gems/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-linux
- GEM PATHS:
- /home5/onalllev/ruby/gems

Thank you

Radek

RE: Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0) - Added by Dave Hudson over 9 years ago

Hi John and Radek.

I'm still stuck trying to get the "rake generate_session_store" command to work.

It keeps saying its missing i18n v0.4.2 although its installed.

I ran ENV['GEM_PATH']='/home1/hdsrobot/ruby/gems' and gem environment appears correct.

How did you solve this?

RE: Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0) - Added by Dave Hudson over 9 years ago

I was able to get past the i18n problem by installing version 1.04 of Redmine and made it all the way through the rest of the install process.

However, when I hit the page, all i get is "Application failed to start".

I noticed before that when I use the bluehost cpanel to set up the initial application, it runs just fine. But once i remove that directory and put the Redmine files in there, I can no longer start the application.

Any advice?

RE: Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0) - Added by Radek Simcik over 9 years ago

Hi Dave

I am not on BlueHost any more, cannot help. Sorry for that.

I am sure you will make it work. I did eventually so.

Radek

RE: Redmine install on bluehost: Could not find RubyGem hoe (>= 1.3.0) - Added by Alex Last over 8 years ago

the same problem here: rake does not see "i18n" gem even after I installed it.
(BLUEHOST)

I wrote about it here: http://www.redmine.org/boards/2/topics/25241

Dave Hudson wrote:

Hi John and Radek.

I'm still stuck trying to get the "rake generate_session_store" command to work.

It keeps saying its missing i18n v0.4.2 although its installed.

I ran ENV['GEM_PATH']='/home1/hdsrobot/ruby/gems' and gem environment appears correct.

How did you solve this?

(1-8/8)