Upgrading to 1.2.0, rake aborted

Added by s s over 9 years ago

Hi!

I'm upgrading to 1.2.0 and get the followig error:

simt@greybit:~/redmine-1.2.0$ rake --trace generate_session_restore

rake/rdoctask is deprecated. Use rdoc/task instead (in RDoc 2.4.2+)
WARNING: 'task :t, arg, :needs => [deps]' is deprecated. Please use 'task :t, [args] => [deps]' instead.
at /home/simt/redmine-1.2.0/lib/tasks/email.rake:170
rake aborted!
Don't know how to build task 'generate_session_restore'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task_manager.rb:49:in `[]'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:111:in `invoke_task'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:90:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:90:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:90:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:129:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:84:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:62:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:129:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:59:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/bin/rake:32
/usr/bin/rake:19:in `load'
/usr/bin/rake:19

I use Debian Lenny and Postgresql, my Versions are like this:


simt@greybit:~/redmine-1.2.0$ gem list

abstract (1.0.0)
actionmailer (3.0.8, 2.3.11, 2.3.5)
actionpack (3.0.8, 2.3.11, 2.3.5)
activemodel (3.0.8)
activerecord (3.0.8, 2.3.11, 2.3.5)
activeresource (3.0.8, 2.3.11, 2.3.5)
activesupport (3.0.8, 2.3.11, 2.3.5)
arel (2.0.10)
builder (2.1.2)
bundler (1.0.14)
daemon_controller (0.2.6)
erubis (2.6.6)
fastthread (1.0.7)
i18n (0.6.0, 0.5.0, 0.4.2)
mail (2.2.19)
mime-types (1.16)
passenger (3.0.7, 2.2.15)
polyglot (0.3.1)
rack (1.2.3, 1.1.2, 1.1.1, 1.0.1)
rack-mount (0.6.14)
rack-test (0.5.7)
rails (3.0.8, 2.3.11, 2.3.5)
railties (3.0.8)
rake (0.9.2, 0.8.7)
rdoc (2.4.2)
thor (0.14.6)
treetop (1.4.9)
tzinfo (0.3.27)

simt@greybit:~/redmine-1.2.0$ ruby --version

ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]

Any ideas?

Replies (1)

RE: Upgrading to 1.2.0, rake aborted - Added by s s over 9 years ago

So, I'm not very familiar with ruby or rake specifically, so I did not interpret the error message of rake.

simt@greybit:~/redmine-1.2.0$ rake --trace generate_session_restore

does not equal:

simt@greybit:~/redmine-1.2.0$ rake --trace generate_session_store

Typo :(

(1-1/1)