Is latest in subversion compatible with Rails 2.2.2?

Added by John Baker over 11 years ago

I need a version of redmine that is compatible with Rails 2.2.2?

If I take the latest from subversion will it work?

Replies (4)

RE: Is latest in subversion compatible with Rails 2.2.2? - Added by Eric Davis over 11 years ago

Not yet. You can check any release by looking at the config/environment.rb file:

...

# Specifies gem version of Rails to use when vendor/rails is not present
RAILS_GEM_VERSION = '2.1.2' unless defined? RAILS_GEM_VERSION

...

There is some work being done in a rails-2.2 branch: http://www.redmine.org/repositories/browse/redmine/branches/work/rails-2.2

Eric

RE: Is latest in subversion compatible with Rails 2.2.2? - Added by John Baker over 11 years ago

Unfortunately, I do not have control of the gem versions installed in the environment I want to deploy. They are always very recent.

Is there a way to deploy the required gems locally within the redmine app so they override?

I am not a ruby programmer but from experience with other languages would guess this should be possible i.e. supply your own dependencies.

RE: Is latest in subversion compatible with Rails 2.2.2? - Added by Jérémy Lal over 11 years ago

i just began some tests with rails 2.2.2 and revision 2479 of redmine.
at first glance, all seems well... then a bug happens in action_mailer,
while submitting an update to an existing issue :

NoMethodError (undefined method `finder' for #<ActionView::Base:0xb6ee3548>):
/vendor/plugins/engines/lib/engines/rails_extensions/action_mailer.rb:73:in `initialize_template_class'

luckily, it's a known bug and that patch fixes the issue, see :
http://github.com/lazyatom/engines/commit/499ce3b0480d8fa9375203f5efcadb8cf6ea9efe

i wonder if i should add an issue for this...

(1-4/4)