Failed to upgrade from 0.7 to 0.8(2361)

Added by hugo joe over 11 years ago

I had a running redmine(0.7) with modrails.
System: debian etch Rails 2.1.2 ruby 1.8.5 (2006-08-25) [i486-linux]

When I upgrade redmine from a SVN checkout, error comes as follow:

rake db:migrate RAILS_ENV="production" --trace
(in /opt/redmine)
  • Invoke db:migrate (first_time)
  • Invoke environment (first_time)
  • Execute environment
    rake aborted!
    /opt/redmine/config/environment.rb:8: syntax error, unexpected tLSHFT
    <<<<<<< .mine
    ^
    /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:in `require'
    /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:355:in `new_constants_in'
    /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:in `require'
    /usr/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/tasks/misc.rake:3
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `call'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:578:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/monitor.rb:238:in `synchronize'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in `invoke_prerequisites'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in `invoke_prerequisites'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/monitor.rb:238:in `synchronize'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in `invoke'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in `invoke_task'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in `standard_exception_handling'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1991:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1970:in `run'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in `standard_exception_handling'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in `run'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31
    /usr/bin/rake:19:in `load'
    /usr/bin/rake:19

I am newbie to ROR. Thanks for your suggestion in advance.

Replies (2)

RE: Failed to upgrade from 0.7 to 0.8(2361) - Added by Jean-Philippe Lang over 11 years ago

This:

<<<<<<< .mine

means that the update is in conflict with some changes you made on your local copy.
You can use svn status to list the files which have conflicts, then resolve them.
See: http://svnbook.red-bean.com/en/1.1/ch03s05.html#svn-ch-3-sect-5.4 for more information.

RE: Failed to upgrade from 0.7 to 0.8(2361) - Added by hugo joe over 11 years ago

Resolved.
I commented out the line(<<<<<<< .mine) in environment.rb.

Thanks.

(1-2/2)