upgrade from 1.3.2 to 2.4.1 problem

Added by Cedric mosnier almost 8 years ago

Hi i try tu upgrade i fail at step 9:

ruby script/rails server webrick -e production fails:
 sudo ruby script/rails server webrick -e production
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- bundler/setup (LoadError)
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /home/mosnier/redmine-2.4.1/config/boot.rb:6:in `<top (required)>'
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from script/rails:5:in `<main>'
mosnier@SRVLINUX:~/redmine-2.4.1$

could you help me i do not understand the error?

Replies (2)

RE: upgrade from 1.3.2 to 2.4.1 problem - Added by Cedric mosnier almost 8 years ago

when i check ruby version:
ruby -v
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]

why does my redmine not using the correct ruby version ?

somes news now i got the following:

It looks like Bundler could not find a gem. This is probably because your
application is being run under a different environment than it's supposed to.
Please check the following:

  • Is this app supposed to be run as the `redmine` user?
  • Is this app being run on the correct Ruby interpreter? Below you will
    see which Ruby interpreter Phusion Passenger attempted to use.
  • Are you using RVM? Please check whether the correct gemset is being used.
  • If all of the above fails, try resetting your RVM gemsets:
    https://github.com/phusion/passenger/wiki/Resetting-RVM-gemsets

-------- The exception is as follows: -------
Could not find i18n-0.6.9 in any of the sources (Bundler::GemNotFound)
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/spec_set.rb:92:in `materialize'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/spec_set.rb:85:in `map!'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/spec_set.rb:85:in `materialize'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/definition.rb:114:in `specs'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/definition.rb:159:in `specs_for'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/definition.rb:148:in `requested_specs'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/environment.rb:18:in `requested_specs'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/runtime.rb:13:in `setup'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler.rb:120:in `setup'
/var/lib/gems/1.8/gems/bundler-1.3.5/lib/bundler/setup.rb:17
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:59:in `gem_original_require'
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:59:in `require'
/var/lib/gems/1.8/gems/passenger-4.0.21/lib/phusion_passenger/loader_shared_helpers.rb:219:in `run_load_path_setup_code'
/var/lib/gems/1.8/gems/passenger-4.0.21/lib/phusion_passenger/loader_shared_helpers.rb:333:in `running_bundler'
/var/lib/gems/1.8/gems/passenger-4.0.21/lib/phusion_passenger/loader_shared_helpers.rb:217:in `run_load_path_setup_code'
/var/lib/gems/1.8/gems/passenger-4.0.21/helper-scripts/rack-preloader.rb:96:in `preload_app'
/var/lib/gems/1.8/gems/passenger-4.0.21/helper-scripts/rack-preloader.rb:150
Application root
/usr/share/redmine
Environment (value of RAILS_ENV, RACK_ENV, WSGI_ENV and PASSENGER_ENV)
production
Ruby interpreter command
/usr/bin/ruby1.8

RE: upgrade from 1.3.2 to 2.4.1 problem - Added by Martin Denizet (redmine.org team member) almost 8 years ago

Them package is named ruby1.9.1 but it actually contains ruby1.9.3. 1.9.1 is the compatibility version. See explanation here .
Just install rubygem and bundler:
  • rubygem: If you installed using your distro packages try:
    apt-get install rubygem
    
  • bundler:
    gem install bundler
    

(1-2/2)