Defect #11482

Output inconsistency during issue creation

Added by Artur Smolarek over 7 years ago. Updated over 7 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Cant reproduce Affected version:2.0.0

Description

When you create a issue throw REST API, returned body can be one of two types:
- body with data like: created issue ID and etc.
- empty body.

The body is empty only if descriptions is longer than ~1000 characters.
Of course in both above situations API returns 201 http code.

Will be good if body contain data (first of all ID of created issue) independently from input data size.

We have confirm this problem in Redmine 2.0.0 & 2.0.3.

History

#1 Updated by Jean-Philippe Lang over 7 years ago

  • Priority changed from High to Normal
  • Resolution set to Cant reproduce

Tested OK with a 3000 character long description. The response body always include the issue representation when creating an issue.

Also available in: Atom PDF