Defect #11885

Filter misses Selectionfield on IE8

Added by Chris Riether almost 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:2.1.1
Resolution:Fixed Affected version:2.1.0

Description

Hi!

1. Thanks for this great tool. Wouldn't want to work without it.

2. I've got a prob with the current version:
Somewhere between 1.3.2-stable (as provided by Ubuntu) and 2.0.3-devel (taken from github) a bug has sneaked in. Just updated to 2.1.0-devel. Still the same.

If I want to filter my issues or Gantt-entries by assignee or author the operator dropdown appears ("is", "is not") but not the field for operand (the "Who"). So I can't complete the filter argument.

Found nothing similar. And so no fix.

Would need it for auditing the new version.

Thx,

Chris

ScreenShot-Redmine.png (8.32 KB) Chris Riether, 2012-09-20 09:48

ie8-js-error.png - IE8 Javascript error screenshot (56.8 KB) Go MAEDA, 2012-09-27 03:25


Related issues

Duplicated by Redmine - Defect #12086: Filter misses Selectionfield on IE8,IE7,IE6 Closed

Associated revisions

Revision 10486
Added by Toshi MARUYAMA almost 10 years ago

fix javascript syntax mistake in application.js (#11885)

Revision 10487
Added by Toshi MARUYAMA almost 10 years ago

fix broken issue list filter (#11885)

Array indexOf() is not defined on IE8.

Revision 10488
Added by Toshi MARUYAMA almost 10 years ago

Merged r10486 from trunk (#11885)

fix javascript syntax mistake in application.js.

Revision 10489
Added by Toshi MARUYAMA almost 10 years ago

Merged r10487 from trunk (#11885)

fix broken issue list filter.

Array indexOf() is not defined on IE8.

History

#1 Updated by Jean-Philippe Lang almost 10 years ago

Could you provide a screenshot, your browser/OS versions and any javascript errors that occur, thanks.

#2 Updated by Chris Riether almost 10 years ago

Hi!

I'm using on User-side Windows 7 with IE 8. My Server is something like an Ubuntu Server 10(?). Don't know where to find any error-scripts.
The Screenshot is from my Ticket-Page of an Project (in german translation). It also occures on filtering Gantt-diagram and calendar (same component?).

Funny thing: if I browse redmine.org it's the same error. So if nobody sees, what I see, it seems to be an interpretation problem in my browser.
Bad thing: I'm forced to use this browser. At the moment, a collegue tests it with firefox. Let's see what happens.

But in the old version it still works... there we were missing something else that has been bugfixed.

Addition: also the highlighting, when selecting tickets, doesn't work in the new version.

Thanks for any help.
Chris

#3 Updated by Chris Riether almost 10 years ago

Hey guys!

Update: collegue found following error output:

Details zum Fehler auf der Webseite
Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; MS-RTC LM 8; .NET4.0C; .NET4.0E)
Zeitstempel: Thu, 20 Sep 2012 09:06:18 UTC
Meldung: Das Objekt unterst├╝tzt diese Eigenschaft oder Methode nicht.
Zeile: 155
Zeichen: 9
Code: 0
URI: http://www.redmine.org/javascripts/application.js?1347200702

Translation:
Details to errors on this website
User-Agent: ...
Message: The object doesn't support this property or method.
Line 155
Char 9
Code...
URI...

on an other IE she got the same error with line 207 (on winXP)

#4 Updated by Chris Riether almost 10 years ago

Hey there!

Nothing new from my side. How about you?
How are the chances to get it fixed soon?
Thanks for any informations. If I can support your efforts, let me know.

Best wishes,
Chris

#5 Updated by Go MAEDA almost 10 years ago

I'm suffering from the same problem. (Windows 7 / Internet Explorer 8)

#6 Updated by Toshi MARUYAMA almost 10 years ago

  • Affected version (unused) changed from devel to 2.1.0
  • Affected version set to 2.1.0

#7 Updated by Toshi MARUYAMA almost 10 years ago

  • Status changed from New to Confirmed
  • Target version set to 2.1.1

#8 Updated by Toshi MARUYAMA almost 10 years ago

  • Subject changed from Filter misses Selectionfield to Filter misses Selectionfield on IE8

#9 Updated by Jean-Philippe Lang almost 10 years ago

  • Status changed from Confirmed to Resolved
  • Resolution set to Fixed

Seems to be fixed by Toshi.

#10 Updated by Chris Riether almost 10 years ago

Thanks! Will try to update it soon.

Best regards,

Chris

#11 Updated by Toshi MARUYAMA almost 10 years ago

  • Status changed from Resolved to Closed

Merged in 2.1-stable.

Also available in: Atom PDF