Defect #1337

konqueror browser support and javascript

Added by Alon Bar-Lev almost 11 years ago. Updated over 5 years ago.

Status:ClosedStart date:2008-05-31
Priority:NormalDue date:2013-02-13
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:No feedback Affected version:

Description

Hello,

Great work!
Was not aware of your project, referenced from [http://trac.edgewall.org/ticket/31 Trac bug]

Some of the user of javascript make konqueror browser not working, I get a lot of errors.

Can you please use more standard javascript to allow more browsers to work?

Also, many people (including my-self) turn off javascript when browsing the internet, for firefox you can do this using noscript extension. As far I can tell, redmine cannot be used with javascript disabled.

Thank you.

BTW: How do you create descriptive reference to site so that URL is not shown? Your Wiki help page is missing.

konqueror.png (28.6 KB) Jean-Philippe Lang, 2008-06-29 21:31

Associated revisions

Revision 1605
Added by Jean-Philippe Lang almost 11 years ago

Makes issue update link work without javascript (#1337).

Revision 1607
Added by Jean-Philippe Lang almost 11 years ago

Redirects back after clicking watch/unwatch links without javascript (#1337).

History

#1 Updated by Alon Bar-Lev almost 11 years ago

BTW: How do you create descriptive reference to site so that URL is not shown? Your Wiki help page is missing.

Found! :)
Trac bug

I expected it to be wiki syle...

#2 Updated by Jean-Philippe Lang almost 11 years ago

I expected it to be wiki syle...

This is the textile style.

#3 Updated by Jean-Philippe Lang almost 11 years ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

Prototype doesn't seem to compatible with Konqueror: http://prototypejs.org/download
Please point to the exact problem as I am not a Konqueror user.

#4 Updated by Alon Bar-Lev almost 11 years ago

  • Status changed from Closed to Reopened

For example, I cannot update this bug, pressing "update" causes:
line 327: TypeError: Value undefined

Also the issue search does not work you cannot add any filter (lots of errors).

I must switch to firefox in order to write this.

Can you please consider supporting scriptless clients? It will provide a solution for almost any browsers, and on Internet this is important almost all trackers (bugzilla, trac and mantis) support scriptless mode.

It is important that all users/clients/customers may have access to bug tracking system if it is available online without restriction on their personal configuration.

Thanks!

#5 Updated by Jean-Philippe Lang almost 11 years ago

I'm currently updating this ticket with Konqueror 3.5.9. Ticket filtering works as well.
Things that do not work:
  • repository ajax browsing (but scriptless browsing works)
  • context menu on the issue list (this menu is just a shortcut, same actions can be accessed from the issue details view)

#7 Updated by Jean-Philippe Lang almost 11 years ago

Issue 'update' link now works with javascript disabled (r1605).
I'll see what I can do for filters.

#8 Updated by Alon Bar-Lev almost 11 years ago

I don't understand how it works for you.
I am also using 3.5.9 and never see the text editor. When I press update it jumps to the middle of the history and does not show the editor.
Strange... but I am guessing I am not the only one.
Thanks!

#9 Updated by Alon Bar-Lev almost 11 years ago

Just a thought... Maybe enable javascript debug messages:
Settings->Configure Konqueror->Java & JavaScript->JavaScript:Enable debugger, Report Errors
Then see if you getting some errors.
Thanks!

#10 Updated by Daniel Felix over 6 years ago

  • Due date set to 2013-02-13

Hi,

is this still a valid defect? Can you give some feedback? I'm not able to reproduce this. Since Redmine uses more jQuery, this could be fixed.

Please give some Feedback until next week. Otherwise i will close this issue.

Best regards,
Daniel

#11 Updated by Jan Niggemann (redmine.org team member) over 5 years ago

  • Status changed from Reopened to Closed
  • Resolution changed from Wont fix to No feedback

Also available in: Atom PDF