Defect #1398

Right Clicking on an issue in a issue list to get native context menu doesn't work in Firefox 3 RC2

Added by David Petersen almost 12 years ago. Updated almost 11 years ago.

Status:ClosedStart date:2008-06-06
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:

Description

Looks like the problem that was in Issue #904 is back with Firefox 3 RC2. You can't right click on the link of a issue and get the native context menu. For people how like to open everything in new tabs this is a problem.

firefox3-kubuntu.png (158 KB) Jean-Philippe Lang, 2008-07-01 19:03

Picture_9.jpg (62.1 KB) Ewan Makepeace, 2008-07-15 12:48

History

#1 Updated by Jean-Philippe Lang almost 12 years ago

I propose to wait for Firefox final release to see if it still occurs.

#2 Updated by Jean-Philippe Lang almost 12 years ago

  • Status changed from New to Closed
  • Affected version (unused) deleted (0.7.1)
  • Resolution set to Invalid
  • Affected version deleted (0.7.1)

It seems to work fine with FF3 final.

#3 Updated by Boudewijn van Liempd almost 12 years ago

Jean-Philippe Lang wrote:

It seems to work fine with FF3 final.

On mac os X (10.5.3) it still doesn't work. When I click outside the issue list it does work but clicking on an issue doesn't work.
Also the "redmine" rightclick menu when f.e. selecting multiple issues to edit them also does not work.

#4 Updated by Boudewijn van Liempd almost 12 years ago

  • Status changed from Closed to Reopened

Boudewijn van Liempd wrote:

Jean-Philippe Lang wrote:

It seems to work fine with FF3 final.

On mac os X (10.5.3) it still doesn't work. When I click outside the issue list it does work but clicking on an issue doesn't work.
Also the "redmine" rightclick menu when f.e. selecting multiple issues to edit them also does not work.

#5 Updated by Boudewijn van Liempd almost 12 years ago

Boudewijn van Liempd wrote:

Boudewijn van Liempd wrote:

Jean-Philippe Lang wrote:

It seems to work fine with FF3 final.

On mac os X (10.5.3) it still doesn't work. When I click outside the issue list it does work but clicking on an issue doesn't work.
Also the "redmine" rightclick menu when f.e. selecting multiple issues to edit them also does not work.

On windows (using VMware Fusion) it is ok

#6 Updated by David Petersen almost 12 years ago

I am still having problems with the final version of Firefox 3.0 on my Mac OS X 10.5.3.

#7 Updated by Gumer Coronel almost 12 years ago

The same for me with Firefox 3.0 on Ubuntu 8.04

#8 Updated by Jean-Philippe Lang almost 12 years ago

Firefox 3.0 / Kubuntu 8.04

#9 Updated by David Petersen almost 12 years ago

This is not resolved on Mac. There are 2 other guys with a Mac in my office that are having the same problem.

#10 Updated by Matthew Kosterman almost 12 years ago

Same problem here. Mac Pro Quad OS X 10.5.2.

#11 Updated by Lane Roathe almost 12 years ago

We've found that when using Safari right clicks work on all of our Mac's. Not sure why Firefox on Mac OS X doesn't work when it works fine in Vista/XP.

#12 Updated by David Petersen almost 12 years ago

Something I have also noticed is that right clicking in google maps doesn't work ether. You can normally right click on the google map and add a new destination, but with Firefox 3 I can't. Have no clue what is causing this.

#13 Updated by Matthew Kosterman almost 12 years ago

Interesting - on a Powerbook G4 running OS X 10.5.2 and Safari 3.0, CONTROL-CLICK works to drop the contextual menu. I don't have a mighty mouse handy to check it but will try to dig one up later.

#14 Updated by Ewan Makepeace almost 12 years ago

I cant get right click context sensitive menus to work in either of my main browsers (Mac):

  • Safari 3.1.2
  • Firefox 3.0

To be honest I only just found out that there was supposed to be custom right click menu behaviour. This is kind of cool (if only it worked) as a shortcut, but I think it very poor UI design to make a right click context sensitive menu the only way to access functionality (in this case bulk edit of multiple issues).

Why? Because in general right click in a browser is reserved for the browsers own right click menu and so users will not intuitively look for a context sensitive menu. Until reopening an issue (#330) I was unaware that the feature had moved to this menu and there is no clue in the UI.

#15 Updated by David Petersen almost 12 years ago

I have and Intel Mac Book Pro running OSX 10.5.4 and Safari 3.1.2 (5525.20.1) and right clicking (and ctrl-clicking) on issue work fine.

#16 Updated by Ewan Makepeace almost 12 years ago

Update: I cannot get right click (or Control click) to work in my own install of Redmine (approx 1 month old) but it does work on this site (www.redmine.org) using Safari 3.1.2. Apologies for the misrepresentation.

I observe the following behaviour:

  • If I ctrl or right click on a single task I get a full right click menu for that task.
  • However if I first check many tasks and then ctrl click (not right click) my action of clicking deselects the task under the cursor, while displaying the smaller menu.

[The behaviour is the same in IE on XP - if you ctrl click it deselects the row, but that is fine because in Windows there is no Ctrl-click convention to represent a right click.]

In Firefox 3 I observe the opposite behaviour:

  • Right clicking has no effect.
  • Ctrl-clicking works as expected without any unintended row deselection.

Question: What version of redmine do I need to upgrade to to get this right click menu behaviour?

#17 Updated by Ewan Makepeace over 11 years ago

We have updated to latest versions and I still cannot get bulk edit to work in Safari (Mac):

  • Redmine 0.7.3.1645 (MySQL)
  • ruby 1.8.6 (2007-03-13 patchlevel 0) [x86_64-linux]
  • Rails 2.0.2
  • Safari 3.1.2

When I right click anywhere on an issue in Safari all I get is the regular Safari context sensitive menu (attached). I know others do not have this problem but it is extremely serious for our wider adoption and I dont know what else to do...

#18 Updated by Brian Lopez over 11 years ago

I have this problem as well with my local install of Redmine 0.7.3 (MySQL)
Using Safari 3.1, latest WebKit nightly, or FF3 in OSX.

Funny thing is, it works here on this site just fine ;)
What version of the code are you guys running?

#19 Updated by Brian Lopez over 11 years ago

I just confirmed that this works with the latest trunk, but not in 0.7.3
My only confusion comes from the fact that 0.7 specifically lists this feature as being part of it.
Not a big deal, I'll just switch to trunk for now - but thought I'd let y'all know

#20 Updated by Carolyn Goodman over 11 years ago

I believe this is the same problem identified in #1655

#21 Updated by Jean-Philippe Lang almost 11 years ago

  • Status changed from Reopened to Closed

Current trunk tested OK with FF3.0.1 under OSX 10.5.6 and Windows.

Also available in: Atom PDF