Defect #14840

Time logging shouldn't be possible for the future periods

Added by Artem Kondratyev over 5 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Duplicate Affected version:

Description

Right how it is possible to log time on any day, which is I believe wrong - you either log the work time spent today or at some point at the past, but not future.

So the basic fix I see here is to validate Spent time date and render an error if it's > current day


Related issues

Duplicates Redmine - Feature #3322: Setting to restrict spent times on future dates Closed 2009-05-08

History

#1 Updated by Go MAEDA over 2 years ago

#2 Updated by Go MAEDA over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #3322.

#3 Updated by Go MAEDA over 2 years ago

#4 Updated by Go MAEDA over 2 years ago

  • Duplicates Feature #3322: Setting to restrict spent times on future dates added

Also available in: Atom PDF