Project

General

Profile

Actions

Feature #15029

closed

When filter by "blocked by" = "any", take into account if blocking issue is already closed (so no really blocking)

Added by Diego Bonfil Traver over 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

I use this filter to filter out some issues that can not be done yet because they are blocked by another one.

But, I think it will be very useful to take into account if the blocking issue is already closed. This way, the initially blocked issue will be no longer blocked.

I like to keep the issues relations, even when the related issues are closed.

I do not know if this is a defect or a feature. If in doubt, can you add some extra values in the filter? I mean, "blocked by" + "any - anytime" + "any - now", ...


Files

redmine_add_relation_filters.patch (5.25 KB) redmine_add_relation_filters.patch Arthur Andersen, 2013-10-28 15:16

Related issues

Has duplicate Redmine - Feature #19171: "any open / none open" filter for ( follows / blocked ) relationshipsClosed

Actions
Is duplicate of Redmine - Feature #16621: Ability to filter issues blocked by any/no open issuesClosedJean-Philippe Lang

Actions
Actions #1

Updated by Arthur Andersen over 10 years ago

I wrote a patch that adds relation filters: 

  • 'any open issues'
  • 'none or closed issues'

Currently only the english localisations were added.

Though I suggest a german translation:

label_any_open_issues: irgendein offenes Ticket
label_none_or_closed_issues: kein Ticket oder geschlossene Tickets
Actions #2

Updated by Arthur Andersen about 10 years ago

I hope this will be merged any time soon. A simple patch, guys. Please :-)

Actions #3

Updated by Toshi MARUYAMA about 10 years ago

  • Related to Feature #16621: Ability to filter issues blocked by any/no open issues added
Actions #4

Updated by Mischa The Evil almost 9 years ago

  • Has duplicate Feature #19171: "any open / none open" filter for ( follows / blocked ) relationships added
Actions #5

Updated by Maxim Nikolaevich over 8 years ago

just FYI: i created patch long time ago for this feature. It was placed #4985#note-7

Actions #6

Updated by Toshi MARUYAMA over 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I think this issue is fixed by #16621.

Actions #7

Updated by Toshi MARUYAMA over 8 years ago

  • Related to deleted (Feature #16621: Ability to filter issues blocked by any/no open issues)
Actions #8

Updated by Toshi MARUYAMA over 8 years ago

  • Is duplicate of Feature #16621: Ability to filter issues blocked by any/no open issues added
Actions

Also available in: Atom PDF