Project

General

Profile

Actions

Defect #16888

closed

Search fails for issues with identical created_on timestamp

Added by Benedikt Huss about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Search engine
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

If you have many issues with an identical created_on timestamp (e.g. 2014-05-14 01:00:00 pm) and all ticket subjects contain the same word (e.g. webservice), there's a bug in the search results.

Imagine there are 20 tickets with the word "webservice" in the subject and all tickets where created on 2014-05-14 01:00:00. Now search for "webservice" in that project. You will see that (at least) 20 issues have been found, the first 14 are displayed. If you switch to the second page, this page is empty, because the specified offset is based on the created_on value.


Related issues

Is duplicate of Redmine - Defect #8815: Invalid search results with pagingClosed2011-07-14

Actions
Actions #1

Updated by Toshi MARUYAMA almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate with #8815.

Actions #2

Updated by Toshi MARUYAMA almost 10 years ago

  • Is duplicate of Defect #8815: Invalid search results with paging added
Actions #3

Updated by Jean-Philippe Lang over 9 years ago

Actions #4

Updated by Jean-Philippe Lang over 9 years ago

  • Related to deleted (Feature #18631: Better search results pagination)
Actions

Also available in: Atom PDF