Project

General

Profile

Actions

Defect #8815

closed

Invalid search results with paging

Added by Oleg Aksenov almost 13 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Search engine
Target version:
-
Start date:
2011-07-14
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

To see this bug try to perform "Search" by any word with more than 10 results.
I reproduced this bug on both my system (1.2.0) and current Redmine.Org version.

To reproduce, please, try this:
http://www.redmine.org/search/index/redmine?issues=1&q=German

10 minutes before posting this bug search produced 73 results. On the last page, I saw only one issue (instead of expected 3).
Surprisingly, after returning to the first page I saw two issues instead of 10.

P.S. On my installation search produced 13 results. On the last page, I saw only two issues (instead of expected 3). And, after returning to the first page I saw 10 issues but one of them was "missing" from last page.


Related issues

Related to Redmine - Defect #8633: Pagination counts non visible issuesClosed2011-06-16

Actions
Has duplicate Redmine - Defect #16888: Search fails for issues with identical created_on timestampClosed

Actions
Is duplicate of Redmine - Defect #16239: Search does not return all the resultsClosed

Actions
Actions #1

Updated by Etienne Massip almost 13 years ago

  • Category set to Search engine
Actions #2

Updated by Etienne Massip almost 13 years ago

  • Affected version (unused) set to 1.2.0
  • Affected version set to 1.2.0
Actions #3

Updated by Toshi MARUYAMA about 10 years ago

  • Has duplicate Defect #16888: Search fails for issues with identical created_on timestamp added
Actions #4

Updated by Toshi MARUYAMA about 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Close as duplicate with #8815.
#8815 has more notes.

Actions #5

Updated by Toshi MARUYAMA about 10 years ago

Toshi MARUYAMA wrote:

Close as duplicate with #8815.
#8815 has more notes.

Sorry, it is #16239, not #8815.

Actions #6

Updated by Toshi MARUYAMA about 10 years ago

  • Is duplicate of Defect #16239: Search does not return all the results added
Actions

Also available in: Atom PDF