Project

General

Profile

Actions

Defect #18866

closed

MySQL: disappear after 4-Byte UTF-8

Added by Алексей Городецкий about 9 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Database
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

When writing tasks text after some characters disappear. For example, after the symbol «


Files

issue.png (29.5 KB) issue.png Toshi MARUYAMA, 2015-01-16 14:29

Related issues

Related to Redmine - Patch #19742: RedmineInstall: MySQL: collation_databaseClosed

Actions
Related to Redmine - Feature #31921: Changes to properly support 4 byte characters (emoji) when database is MySQLClosedGo MAEDA

Actions
Has duplicate Redmine - Defect #10779: redmine cannot deal with 4-byte utf-8 charactersClosed

Actions
Has duplicate Redmine - Defect #10772: 4-byte utf-8 charactersClosed

Actions
Has duplicate Redmine - Defect #21679: Emoji [CL] will break the subject of new ticketsClosed

Actions
Actions #1

Updated by Алексей Городецкий about 9 years ago

林 业文 writing tasks text after some characters disappear. For example, after the symbol «

Actions #2

Updated by Toshi MARUYAMA about 9 years ago

after the symbol « after the symbol « after the symbol «

Actions #3

Updated by Toshi MARUYAMA about 9 years ago

I cannot reproduce.

Environment:
  Redmine version                2.5.3.stable
  Ruby version                   1.9.3-p551 (2014-11-13) [x86_64-linux]
  Rails version                  3.2.19
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.6.11
  Mercurial                      2.8.2
  Bazaar                         2.1.1
  Git                            1.7.1
  Filesystem                     
Redmine plugins:
  no plugin installed
Actions #4

Updated by Имя Фамилия about 9 years ago

For example, after the symbol "􀀀". This symbol was been encoded for this message as

􀀀
. Copy this message to reproduce.

Actions #5

Updated by Имя Фамилия about 9 years ago

Copy:
For example, after the symbol "

Actions #6

Updated by Toshi MARUYAMA about 9 years ago

  • Category changed from Issues to Database
  • Status changed from Needs feedback to New

The utf8mb4 Character Set (4-Byte UTF-8 Unicode Encoding)
http://dev.mysql.com/doc/refman/5.6/en/charset-unicode-utf8mb4.html

Actions #7

Updated by Toshi MARUYAMA about 9 years ago

http://www.fileformat.info/info/unicode/char/100000/index.htm

UTF-8 (hex) 0xF4 0x80 0x80 0x80 (f4808080)

Actions #8

Updated by Toshi MARUYAMA about 9 years ago

  • Subject changed from When writing tasks text disappears after some characters to MySQL: disappear after 4-Byte UTF-8
Actions #9

Updated by Toshi MARUYAMA almost 9 years ago

  • Related to Patch #19742: RedmineInstall: MySQL: collation_database added
Actions #10

Updated by Toshi MARUYAMA almost 9 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate
Actions #11

Updated by Toshi MARUYAMA almost 9 years ago

Actions #12

Updated by Toshi MARUYAMA almost 9 years ago

  • Related to deleted (Patch #19742: RedmineInstall: MySQL: collation_database)
Actions #13

Updated by Toshi MARUYAMA almost 9 years ago

  • Status changed from Closed to New
  • Resolution deleted (Duplicate)
Actions #14

Updated by Toshi MARUYAMA almost 9 years ago

  • Related to Patch #19742: RedmineInstall: MySQL: collation_database added
Actions #15

Updated by Toshi MARUYAMA almost 9 years ago

Try utf8mb4 (#10772#note-7).

Actions #16

Updated by Toshi MARUYAMA almost 9 years ago

  • Has duplicate Defect #10779: redmine cannot deal with 4-byte utf-8 characters added
Actions #17

Updated by Toshi MARUYAMA almost 9 years ago

  • Status changed from New to Closed
Actions #18

Updated by Toshi MARUYAMA almost 9 years ago

  • Status changed from Closed to New
Actions #19

Updated by Toshi MARUYAMA almost 9 years ago

  • Has duplicate deleted (Defect #10779: redmine cannot deal with 4-byte utf-8 characters)
Actions #20

Updated by Toshi MARUYAMA almost 9 years ago

  • Is duplicate of deleted (Defect #10772: 4-byte utf-8 characters)
Actions #21

Updated by Toshi MARUYAMA almost 9 years ago

  • Has duplicate Defect #10779: redmine cannot deal with 4-byte utf-8 characters added
Actions #22

Updated by Toshi MARUYAMA almost 9 years ago

Actions #23

Updated by Toshi MARUYAMA over 8 years ago

  • Has duplicate Defect #21679: Emoji [CL] will break the subject of new tickets added
Actions #24

Updated by Marius BĂLTEANU over 4 years ago

  • Related to Feature #31921: Changes to properly support 4 byte characters (emoji) when database is MySQL added
Actions #25

Updated by Marius BĂLTEANU 5 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Issues #31921, #32140 and HowTo_convert_a_database_from_utf8_to_utf8mb4 page contain enough information to identify the issues caused by utf8 and to migrate the database to utf8mb4.

Closing this as duplicate.

Actions

Also available in: Atom PDF