Project

General

Profile

Actions

Feature #32140

closed

Document MySQL database migration to utf8mb8

Added by Sylvain Faivre over 4 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Documentation
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Feature #31921 included in 4.1.0 sets utf8mb4 as default encoding for new MySQL databases setups.

In the description, Marius BALTEANU added :

I'll try to create later a Wiki page regarding the steps required to migrate and existing installation or at least some useful links.

There is no documentation explaining how to migrate yet.

#21398 includes a migration script, but people in that thread reported failures with the script.

Actions #1

Updated by Go MAEDA almost 4 years ago

  • Category changed from Database to Documentation
Actions #2

Updated by C S about 3 years ago

According to my knowledge, I have created the following HowTo: HowTo_convert_a_database_from_utf8_to_utf8mb4

Actions #3

Updated by Sylvain Faivre about 3 years ago

Sorry I didn't get back to this issue before.
Migrating a MySQL/MariaDB database to utf8mb4 might require a lot of steps, depending on the MySQL or MariaDB release you have.
I actually migrated our Redmine database using the Nextcloud documentation, which thoroughly describes each case.
This documentation can be found at https://docs.nextcloud.com/server/20/admin_manual/configuration_database/mysql_4byte_support.html

I also had to edit the config/database.yml file in Redmine folder, to alter this entry :

  encoding: utf8mb4

Actions #4

Updated by C S over 2 years ago

I've made a few changes to the description

Actions #5

Updated by Marius BĂLTEANU 6 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

This issue, #31921 and HowTo_convert_a_database_from_utf8_to_utf8mb4 page contain enough information to identify the issues caused by utf8 and to migrate the database to utf8mb4.

Closing this as duplicate.

Actions

Also available in: Atom PDF