Defect #19321

MinGW thin and puma: non ASCII wiki page causes "Internal server error"

Added by Eugene B over 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Wont fix Affected version:3.0.0

Description

We were using 2.4.1 Bitnami installation for about a year with no problems. After 3.0.0 release we have switched to this new version to be sure we are using current Redmine branch, and our installation is not so outdated. We are using Bitnami 3.0.0 installer for windows platforms.

We have found a problem, that if a wiki page contains russian word "Информация" (tranlation: Information) written with capital letter only! If this word is present in wiki page name (no matter if it is first word in wiki page name or it will be one of the next words) it will lead to "Internal server error" while trying to access a page.

For example:
"Справочная информация" - this wiki page name opens normal
"Справочная Информация" - this wiki page name will lead to "Internal server error" error message

"информация по учетным записям трекеров контейнерных линий" - this wiki page name opens normal
"Информация по учетным записям трекеров контейнерных линий" - this wiki page name will lead to "Internal server error" error message

All other wiki pages, tasks, everyting works correct. We have run migration two times:
this way
rake db:migrate RAILS_ENV=production
and this way:
set RAILS_ENV=production
rake db:migrate

migration reports no errors.

Later we noticed, that actually a broken page exists, and we can open it by changing letter "И" from capital to "и" at the browser address line. We had so far only 5 problem pages, and we renamed them all to use small "и" letter at the wiki page name. This is of course a workaround, and problem exists.

To confirm error, we have installed clean Redmine 3.0.0 instance from bitname at another PC and tried to make a wiki page there using "Информация" word, mistake is the same. So I think its not a DB migration error, its most likely error in Redmine itself (or probably some conflict with software that bitnami intaller uses)

windows-thin.png (76.3 KB) Toshi MARUYAMA, 2015-03-26 13:54


Related issues

Related to Redmine - Defect #19374: MinGW thin and puma: Internal server error occoures when ... Closed
Duplicated by Redmine - Defect #19609: Internal server error, when using Korea character (maybe ... Closed
Duplicated by Redmine - Defect #19978: The problem with Russian letter 'И' in the Wiki Closed

History

#1 Updated by Eugene B over 2 years ago

Host PC Win 8.1

c:\Redmine\3.0.0\apps\redmine\htdocs>ruby script/about
script/about no longer exists, please use bin/about instead.

c:\Redmine\3.0.0\apps\redmine\htdocs>ruby bin/about
DL is deprecated, please use Fiddle

Environment:
Redmine version 3.0.0.stable
Ruby version 2.0.0-p594 (2014-10-27) [i386-mingw32]
Rails version 4.2.0
Environment production
Database adapter Mysql2
SCM:
Subversion 1.8.10
Git 1.9.5
Filesystem
Redmine plugins:
no plugin installed

c:\Redmine\3.0.0\apps\redmine\htdocs>

The bug is very easy to observe, just >>>get<<< latest 3-0-0 installation from bitnami, install it. Create any test project, and there try to create a Wiki page with "Информация" word. I have checked log file, but it reports no error...

At the log we see that I am browsing some wiki pages, but after each of them, I try to open wiki page, that leads to "Internal server error" This makes no recordings to log file:

#2 Updated by Eugene B over 2 years ago

Also discussing problem on Bitnami forum: https://community.bitnami.com/t/2-problems-with-3-0-0-installation-see-reports-inside/30195

They have asked some more details, please also find them here:

Link to my log files: https://cloud.mail.ru/public/7261d0e62c8e/logs.zip (from C:\Redmine\3.0.0\apps\redmine\htdocs\log and C:\Redmine\3.0.0\apache2\logs)
I have cleaned them before redmine restart, so its not much to see there. I see nothing special there. Probably I need to set more thorough log mode? If possible, please tell me how to do it.

Also please find link to youtube with video recording for this problem. http://youtu.be/r3TITwOP_Fk

#3 Updated by Eugene B over 2 years ago

If there are some problems to reproduce or confirm bug, I can give teamviewer access to affected PC if its needed. So it will be easier to get required information. Contact me with e-mail at my profile if interested.

#4 Updated by Jean-Philippe Lang over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

This error (and the error page I can see on your video) comes from your webserver, not Redmine.
I've setup an example on the demo site, and it works fine: http://demo.redmine.org/projects/test19321/wiki/Wiki

#5 Updated by Eugene B over 2 years ago

  • Status changed from Closed to Reopened

Sorry for disturbing you again ^^ But Im still here with my problem. Still actual for 3.0.1 too.

Apache team responded with the following:

Try LogLevel trace8 and attaching the errorlog directly to this bug report.  Presumably the encoding of that character matches some blacklisted octet for the platform httpd is on.
It seems that the redmine itself (127.0.0.1:3001) responds with status 500 (Internal Server Error) with path "/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F", mod_proxy is simply forwarding that error response.
You probably have to check redmine's logs for the original cause.

My thread at Apache bugtracker: https://bz.apache.org/bugzilla/show_bug.cgi?id=57726

I have tried to find out the how to solve the problem both at Bitnami Team Forum and at Apache bugtracker (since apache reports error) I have tried to set debug log level for redmine production, but it makes not recordings for my error.

The bad thing is that this mistake is not critical, I can rename all pages at Wiki so it will not use this word at the browser address line, but this is so clumsy :( I understand that from your point it Redmine seems to be running OK, as you can not reproduce the bug on your demo site, but I suppose you host it on some other software, linux based or else, so Its not 1:1 reproduction. (you can directly reproduce if you will get Bitnami intaller for windows)

I am here again because I doubt anyone else will solve it. Bitnami team almost dont take part at discussion for this error and Apache points to Redmine (as you point to them :P) If you will close thread again, I give up ) I dont have enough expirience to deal with it.

#6 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #19374: MinGW thin and puma: Internal server error occoures when attachment file name contains non ASCII added

#7 Updated by Eugene B over 2 years ago

Another report for similar issue on Bitnami site:

https://community.bitnami.com/t/problem-with-some-links-in-wiki/30537

#8 Updated by Eugene B over 2 years ago

More information, any word (or even just any letters) that contains capital "И" letter leads to problem
"История" (history) "Интервал" (interval) "авеИавы" (just random letters with big "И")

#9 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from Reopened to Closed

I cannot reproduce on my CentOS6.

$ LANG=C rpm -qi httpd
Name        : httpd                        Relocations: (not relocatable)
Version     : 2.2.15                            Vendor: CentOS
Release     : 39.el6.centos                 Build Date: Thu Oct 16 23:49:26 2014
Install Date: Mon Nov  3 10:06:52 2014         Build Host: c6b9.bsys.dev.centos.org
Group       : System Environment/Daemons    Source RPM: httpd-2.2.15-39.el6.centos.src.rpm
Size        : 3085394                          License: ASL 2.0
Signature   : RSA/SHA1, Sat Oct 18 05:02:19 2014, Key ID 0946fca2c105b9de
Packager    : CentOS BuildSystem <http://bugs.centos.org>
URL         : http://httpd.apache.org/
Summary     : Apache HTTP Server
Description :
The Apache HTTP Server is a powerful, efficient, and extensible
web server.
$ cat /etc/httpd/conf.d/proxy.conf
Listen 3010

<VirtualHost *:3010>
  ProxyPass / http://localhost:3000/
  ProxyPassReverse / http://localhost:3000/
</VirtualHost>

/var/log/httpd/access_log:

::1 - - [26/Mar/2015:06:03:35 +0900] "GET /projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F HTTP/1.1" 200 7639 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /stylesheets/application.css HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /javascripts/jquery-1.11.1-ui-1.11.0-ujs-3.1.1.js HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /javascripts/application.js HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /javascripts/application.js HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /javascripts/attachments.js HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /javascripts/jquery-1.11.1-ui-1.11.0-ujs-3.1.1.js HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /stylesheets/jquery/jquery-ui-1.11.0.css HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /javascripts/attachments.js HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /stylesheets/jquery/jquery-ui-1.11.0.css HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F HTTP/1.1" 200 7639 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /stylesheets/application.css HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /images/fav_off.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /images/locked.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /images/move.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /images/delete.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /images/delete.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /images/history.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /images/fav_off.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /images/locked.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /images/edit.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /images/edit.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
::1 - - [26/Mar/2015:06:03:35 +0900] "GET /images/history.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 
192.168.11.10 - - [26/Mar/2015:06:03:35 +0900] "GET /images/move.png HTTP/1.1" 304 - "http://192.168.11.11:3010/projects/hg-crew-00/wiki/%D0%98%D0%BD%D1%84%D0%BE%D1%80%D0%BC%D0%B0%D1%86%D0%B8%D1%8F" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36" 

log/production.log:

Started GET "/projects/hg-crew-00/wiki/%d0%98%d0%bd%d1%84%d0%be%d1%80%d0%bc%d0%b0%d1%86%d0%b8%d1%8f" for ::1 at 2015-03-26 06:03:35 +0900
Processing by WikiController#show as HTML
  Parameters: {"project_id"=>"hg-crew-00", "id"=>"Информация"}
  Current user: admin (id=1)
  Rendered wiki/_content.html.erb (49.9ms)
  Rendered attachments/_form.html.erb (2.2ms)
  Rendered wiki/_sidebar.html.erb (1.4ms)
  Rendered wiki/show.html.erb within layouts/base (60.0ms)
Completed 200 OK in 85ms (Views: 76.3ms | ActiveRecord: 1.8ms)

#11 Updated by Toshi MARUYAMA about 2 years ago

On my Japanese Windows 8.1 Pro.

#12 Updated by Toshi MARUYAMA about 2 years ago

Unexpected error while processing request: "\x80" on Windows-31J
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_disp
atch/middleware/static.rb:34:in `file?'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_disp
atch/middleware/static.rb:34:in `block in match?'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_disp
atch/middleware/static.rb:31:in `each'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_disp
atch/middleware/static.rb:31:in `detect'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_disp
atch/middleware/static.rb:31:in `match?'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_disp
atch/middleware/static.rb:107:in `call'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rack-1.6.0/lib/rack/sendfile.rb:
113:in `call'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/engine.
rb:518:in `call'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/applica
tion.rb:164:in `call'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/railtie
.rb:194:in `public_send'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/railtie
.rb:194:in `method_missing'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/connection.r
b:86:in `block in pre_process'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/connection.r
b:84:in `catch'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/connection.r
b:84:in `pre_process'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/connection.r
b:53:in `process'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/connection.r
b:39:in `receive_data'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/eventmachine-1.0.7/lib/eventmach
ine.rb:187:in `run_machine'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/eventmachine-1.0.7/lib/eventmach
ine.rb:187:in `run'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/backends/bas
e.rb:73:in `start'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/server.rb:16
2:in `start'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/controllers/
controller.rb:87:in `start'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/runner.rb:20
0:in `run_command'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/lib/thin/runner.rb:15
6:in `run!'
        c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thin-1.6.3/bin/thin:6:in `<top (
required)>'
        c:/Ruby200-x64/bin/thin:23:in `load'
        c:/Ruby200-x64/bin/thin:23:in `<main>'

#13 Updated by Toshi MARUYAMA about 2 years ago

$ cat Gemfile.local
gem "thin" 
$ thin start
Using rack adapter
Thin web server (v1.6.3 codename Protein Powder)
Maximum connections set to 1024
Listening on 0.0.0.0:3000, CTRL+C to stop

#15 Updated by Eugene B about 2 years ago

Toshi, thanks!!!

#16 Updated by Toshi MARUYAMA about 2 years ago

I tried puma.

Puma caught this error: "\x80" on Windows-31J (Encoding::InvalidByteSequenceError)
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_dispatch/middleware/static.rb:34:in `file?'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_dispatch/middleware/static.rb:34:in `block in match?'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_dispatch/middleware/static.rb:31:in `each'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_dispatch/middleware/static.rb:31:in `detect'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_dispatch/middleware/static.rb:31:in `match?'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/actionpack-4.2.1/lib/action_dispatch/middleware/static.rb:107:in `call'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rack-1.6.0/lib/rack/sendfile.rb:113:in `call'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/engine.rb:518:in `call'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/application.rb:164:in `call'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/railtie.rb:194:in `public_send'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.2.1/lib/rails/railtie.rb:194:in `method_missing'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/puma-2.11.1/lib/puma/rack_patch.rb:13:in `call'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/puma-2.11.1/lib/puma/configuration.rb:82:in `call'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/puma-2.11.1/lib/puma/server.rb:507:in `handle_request'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/puma-2.11.1/lib/puma/server.rb:375:in `process_client'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/puma-2.11.1/lib/puma/server.rb:262:in `block in run'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/puma-2.11.1/lib/puma/thread_pool.rb:104:in `call'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/puma-2.11.1/lib/puma/thread_pool.rb:104:in `block in spawn_thread'

#17 Updated by Eugene B about 2 years ago

https://github.com/marutosi/rails/commit/c53a49e0bbe615d5ff51620a993c4d3d79c73370

I have updated line 32 at my file \apps\redmine\htdocs\vendor\bundle\ruby\2.0.0\gems\actionpack-4.2.0\lib\action_dispatch\middleware\static.rb

Your fix works! Thank you.

#19 Updated by Toshi MARUYAMA about 2 years ago

  • Subject changed from Wiki page with specific word at page name causes "Internal server error" to MinGW thin and puma: non ASCII wiki page cause "Internal server error"

#20 Updated by Toshi MARUYAMA about 2 years ago

  • Subject changed from MinGW thin and puma: non ASCII wiki page cause "Internal server error" to MinGW thin and puma: non ASCII wiki page causes "Internal server error"

#21 Updated by Toshi MARUYAMA about 2 years ago

  • Duplicated by Defect #19609: Internal server error, when using Korea character (maybe 2byte character) in Wiki added

#22 Updated by Toshi MARUYAMA about 2 years ago

  • Duplicated by Defect #19600: can't open attcment files that have hebrow file names added

#23 Updated by Toshi MARUYAMA about 2 years ago

  • Duplicated by deleted (Defect #19600: can't open attcment files that have hebrow file names)

#24 Updated by Toshi MARUYAMA almost 2 years ago

Rails 4.2.3 fixed.

$ git tag --contains 4df216cb12e35
v4.2.3
v4.2.3.rc1

#25 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicated by Defect #19978: The problem with Russian letter 'И' in the Wiki added

#26 Updated by Toshi MARUYAMA over 1 year ago

  • Resolution changed from Invalid to Wont fix

Also available in: Atom PDF