Defect #19600

can't open attcment files that have hebrow file names

Added by moran kaye about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Attachments
Target version:-
Resolution:Duplicate Affected version:

Description

when I try to open an attcment files that has hebrow file name
I get ah error the website can not be desplayed in IE11

ניסון.txt Magnifier (5 Bytes) moran kaye, 2015-04-13 10:01

ניסוןאבגדהוזחטי.txt Magnifier (5 Bytes) moran kaye, 2015-04-13 10:04

system.jpg (26.9 KB) moran kaye, 2015-05-05 14:42


Related issues

Duplicates Redmine - Defect #19374: MinGW thin and puma: Internal server error occoures when ... Closed

History

#2 Updated by Toshi MARUYAMA about 7 years ago

  • Status changed from New to Needs feedback

#3 Updated by moran kaye about 7 years ago

Environment:
Redmine version 3.0.1.stable
Ruby version 2.0.0-p594 (2014-10-27) [i386-mingw32]
Rails version 4.2.0
Environment production
Database adapter Mysql2
SCM:
Filesystem
Redmine plugins:
no plugin installed

#4 Updated by Toshi MARUYAMA about 7 years ago

Do you use bitnami or thin or puma?

#5 Updated by moran kaye about 7 years ago

local host

#6 Updated by Toshi MARUYAMA about 7 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

There is no instructive answer, but I think duplicate of #19321.

#7 Updated by Toshi MARUYAMA about 7 years ago

  • Duplicates Defect #19321: MinGW thin and puma: non ASCII wiki page causes "Internal server error" added

#8 Updated by moran kaye about 7 years ago

I have updated line 32 at my file \apps\redmine\htdocs\vendor\bundle\ruby\2.0.0\gems\actionpack-4.2.0\lib\action_dispatch\middleware\static.rb

like Defect #19321 sujested

Your fix works!
Thank you.

#9 Updated by Toshi MARUYAMA about 7 years ago

  • Related to Defect #19374: MinGW thin and puma: Internal server error occoures when attachment file name contains non ASCII added

#10 Updated by Toshi MARUYAMA about 7 years ago

  • Related to deleted (Defect #19374: MinGW thin and puma: Internal server error occoures when attachment file name contains non ASCII)

#11 Updated by Toshi MARUYAMA about 7 years ago

  • Duplicates Defect #19374: MinGW thin and puma: Internal server error occoures when attachment file name contains non ASCII added

#12 Updated by Toshi MARUYAMA about 7 years ago

  • Duplicates deleted (Defect #19321: MinGW thin and puma: non ASCII wiki page causes "Internal server error")

Also available in: Atom PDF