Patch #221

Textilized timelog comments

Added by Balazs Dan over 15 years ago. Updated over 12 years ago.

Status:ClosedStart date:2007-06-26
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-

Description

Hi,

We use timelog comments to display what changes has been made during the given time. But 1 line is usually too short.
So I made this little patch..

Jean, huge thanks for this masterpiece! We love it! :)

BR,
Balazs

timelog_comments.patch Magnifier (2.85 KB) Balazs Dan, 2008-02-03 11:01


Related issues

Duplicates Redmine - Feature #202: Textilization of Documents, News and Timelog-entry comments New

History

#1 Updated by Mischa The Evil about 13 years ago

  • Category set to Text formatting
  • Status changed from New to Closed

Balazs Dan wrote:

We use timelog comments to display what changes has been made during the given time. But 1 line is usually too short.
So I made this little patch..

Thanks for adding this patch. Actually your patch does some more then only textilize the timelog comments on the timelog report. It also intends to / does (I haven't tested it on recent trunk):
  1. remove the maximum comment length validation for 255 chars
  2. add a validation to make sure at least one char is added as a timelog comment
  3. textilizes the timelog comments on the timelog report
  4. change the timelog new/edit views to modify the timelog comment field with a size of 100% to a text_area with a size of 60 cols by 15 rows, with the CSS-class wiki-edit, and which content is required
  5. add the wiki toolbar to the timelog new/edit views
  6. change the DB-structure to handle timelog comments longer then 255 chars (changed the comments column's type from string, 255 to text)

I've extracted number 3 from above to combine it with issue #202. Regarding this point this issue can now be considered as a duplicate of #202.
Regarding the other numbers above I'd suggest to rebase the changes to the current trunk and to post it as a new patch, as far as there is still a need to keep this actual patch alive.

I'll now close this issue as a partial duplicate of #202.

#2 Updated by Mischa The Evil over 12 years ago

  • Start date set to 2007-06-26

Also available in: Atom PDF