Defect #22932

"Group by" row from issues listing has the colspan attribute bigger with one than the number of columns from the table

Added by Marius BALTEANU about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI
Target version:3.2.3
Resolution:Fixed Affected version:3.2.2

Description

Steps to reproduce:
  1. Open the issues tabs
  2. Group results by an attribute (tracker for example)
  3. Observe that the colspan attribute of the "Group by" row (tr.group) is bigger with one than the number of columns of issue rows (tr.issue).
  4. Because of that, the right border is missing for issue rows and table header

After applying the attached patch (fix_colspan_attribute.patch):

missing_border.png (143 KB) Marius BALTEANU, 2016-05-31 01:19

fix_colspan_attribute.patch Magnifier (880 Bytes) Marius BALTEANU, 2016-05-31 01:23

with_border.png (152 KB) Marius BALTEANU, 2016-05-31 01:25

fix_colspan_attribute_v2.patch Magnifier (706 Bytes) Marius BALTEANU, 2016-05-31 11:36

Associated revisions

Revision 15452
Added by Jean-Philippe Lang about 2 years ago

Fixed colspan value (#22932).

Patch by Marius BALTEANU.

History

#1 Updated by Marius BALTEANU about 2 years ago

Sorry, previous patch version contains an error. Attached the correct one (_v2).

#2 Updated by Go MAEDA about 2 years ago

  • Target version set to 3.2.3

Confirmed the problem in Safari and Chrome. No problem in Edge and Firefox.

#3 Updated by Jean-Philippe Lang about 2 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Committed, thanks for this fix.

Also available in: Atom PDF