Feature #23529

Calculate parent Issue's done ratio from subtasks in case of 'Use the issue status'

Added by Haihan Ji over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

Admin -> Settings -> Issue Tracking:

Calculate the issue done ratio with => 'Use the issue status'
Parent tasks attributes : % Done => Calculated from subtasks

If I set NEW is 0%, CLOSED is 100%.
When all subtasks are closed, the parent issue still is 0% (status is NEW).
But I hope it be 100%.

Can you add a switch? Force calculate the parent done ratio from subtasks?


Related issues

Duplicates Redmine - Defect #6609: % Done for Parent Tasks [2] Reopened 2010-10-08

History

#2 Updated by Toshi MARUYAMA over 1 year ago

  • Subject changed from Calculate parent Issue's done ratio from subtasks to Calculate parent Issue's done ratio from subtasks in case of 'Use the issue status'

#3 Updated by Kamil Franckiewicz over 1 year ago

vote +1

#4 Updated by Go MAEDA over 1 year ago

  • Duplicates Defect #6609: % Done for Parent Tasks [2] added

#5 Updated by Go MAEDA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I am closing this issue as a duplicate of #6609.
Thank you for submitting this issue.

Also available in: Atom PDF