Patch #23888

Show an error message when changing an issue's project fails due to errors in child issues

Added by Jens Krämer 6 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:3.4.0

Description

The problem occurs for example when child issues have trackers that aren't present in the destination project. This very simple solution just displays a generic error message if the save is aborted due to a failing child save.

0001-adds-an-error-message-to-be-displayed-when-issue-sav.patch Magnifier - patch against current trunk (2.2 KB) Jens Krämer, 2016-09-22 08:17

0001-fix-german-locale-string-23888.patch Magnifier (985 Bytes) Jens Krämer, 2016-12-19 06:32


Related issues

Related to Redmine - Defect #15319: Can't Move Parent Ticket Between Projects Closed
Related to Redmine - Defect #11148: Moving issues with sub issues between projects fails Closed

Associated revisions

Revision 16089
Added by Jean-Philippe Lang 3 months ago

Show an error message when changing an issue's project fails due to errors in child issues (#23888).

Revision 16090
Added by Jean-Philippe Lang 3 months ago

Add :error_move_of_child_not_possible i18n string (#23888).

Revision 16102
Added by Jean-Philippe Lang 3 months ago

Fix german locale string #23888.

Patch by Jens Kraemer.

History

#1 Updated by Jens Krämer 6 months ago

possibly related to #15319

#2 Updated by Toshi MARUYAMA 5 months ago

  • Related to Defect #15319: Can't Move Parent Ticket Between Projects added

#3 Updated by Toshi MARUYAMA 5 months ago

  • Target version set to 3.4.0

#4 Updated by Jean-Philippe Lang 3 months ago

  • Subject changed from show an error message when changing an issue's project fails due to errors in child issues to Show an error message when changing an issue's project fails due to errors in child issues
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang

Message changed to a bit more specific one that includes the ID and the cause of the failure, eg: "Subtask #NNN could not be moved to the new project: Tracker is not included in the list".
It includes details about the first child that fails but I think it's more usefull to know what to look for exactly.

Please check that the german message is OK.

#5 Updated by Jens Krämer 3 months ago

small fix for the german wording

#6 Updated by Jean-Philippe Lang 3 months ago

  • Status changed from Reopened to Closed

Thanks.

#7 Updated by Go MAEDA 2 months ago

  • Related to Defect #11148: Moving issues with sub issues between projects fails added

Also available in: Atom PDF