Defect #24582

Time Report Week does not honor Start day in Settings

Added by Matthew Paul almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Duplicate Affected version:3.2.0

Description

Administration>Settings>Display>Start Calendar on>Monday
Project>Overview>Spent Time>Report
Date>Last Week
Report>Details>Days>Add>Issue
Should display Mon-Sun. Instead Displays Mon-Sat
Same for if you do This Week on a sunday - should display Mon-Sun but instead displays a single day - today - because it uses today (sun) as day 1 of new week instead of correctly calculating today as the day 7 of this week.

Environment:
Redmine version 3.2.0.stable
Ruby version 2.1.8-p440 (2015-12-16) [x86_64-linux]
Rails version 4.2.5
Environment production
Database adapter Mysql2


Related issues

Duplicates Redmine - Defect #13547: Start calendars on not work Confirmed

History

#1 Updated by Go MAEDA almost 6 years ago

#2 Updated by Go MAEDA almost 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #13547.
Thank you for reporting this.

Also available in: Atom PDF