Project

General

Profile

Actions

Defect #2546

closed

Cannot view RSS feeds in Safari

Added by Joe Chin about 15 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Feeds
Target version:
-
Start date:
2009-01-20
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

RSS feeds in Safari/OSX no longer work. Same problem when using Apple Mail RSS subscription. Something has changed in the format because this worked perfectly before.

"The feed could not be loaded because the content is not in a known feed format." (PubSub:2)


Files

Picture_1.png (76.5 KB) Picture_1.png Joe Chin, 2009-01-22 10:10
lister.atom (3.61 KB) lister.atom Joe Chin, 2009-01-22 10:10
Actions #1

Updated by Jean-Philippe Lang about 15 years ago

I did a quick test with Safari. It seems to work fine.
Can you attach the feed content please?

Actions #2

Updated by Joe Chin about 15 years ago

I installed from SVN so maybe something has changed in the development copy. I have included a screenshot as well as a copy of the RSS feed.

Actions #3

Updated by Joe Chin about 15 years ago

Redmine 0.8.0.devel.2264 (MySQL)

Actions #4

Updated by Jean-Philippe Lang about 15 years ago

Not able to reproduce.
I have Safari 3.2.1 that displays your atom file just fine.

Actions #5

Updated by Jean-Philippe Lang almost 15 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce
Actions #6

Updated by Eric Allen over 14 years ago

  • Status changed from Closed to Reopened

The issue seems to be not the data format, but how it's transferred. I can download the feed from my Redmine server and open the file in Safari just fine, but visiting the feed URL fails. MIME type issue, maybe?

Actions #7

Updated by Eric Allen over 14 years ago

Oh, and this is showing up in Redmine 0.8.5. Doesn't seem to be a problem at redmine.org, so maybe it's been fixed in trunk.

Actions #8

Updated by Luca Pireddu over 14 years ago

Try using the Atom feed instead of RSS

Actions #9

Updated by Daniel Felix about 11 years ago

  • Status changed from Reopened to Closed

I'm not able to reproduce this anymore.

This seems to be fixed. I'm closing this issue.

Actions

Also available in: Atom PDF