Project

General

Profile

Actions

Defect #2566

closed

regular "An internal server error occurred. Please try again later." error

Added by Thomas D about 15 years ago. Updated almost 15 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-01-23
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

This error happens systematically after a day of running.
This is on CentOS 5, in a virtual environment (OpenVZ).

I start Redmine with the following command: "ruby script/server -e production -p 80 -d -u"
After a day, it will reply with the above error message, even if the server is totally unused. Memory is not the culprit and the various system logs do not reflect any problem.
The production log file shows the last access that worked and nothing else.

This is 100% reproducible. Let me know what data I can provide.

Actions #1

Updated by Jean-Philippe Lang about 15 years ago

This error message: "An internal server error occurred. Please try again later." is not a Redmine error message.
Do you have any reverse proxy in front of it?

Actions #2

Updated by Thomas D about 15 years ago

yes, I have; I should have thought of that...

I tried to connect directly to the server, on the host, and it simply does not reply

Actions #3

Updated by Jean-Philippe Lang about 15 years ago

let me know what data I can provide

Maybe you can start with what is mentioned in SubmittingBugs.
Honestly, this problem can come from many things, like a broken connection to the database (see http://wooga.drbacchus.com/rails-and-mysql-timeouts).

Actions #4

Updated by Jean-Philippe Lang almost 15 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

Reopen if needed.

Actions

Also available in: Atom PDF