Defect #26377

500 Internal Server Error while search in projects

Added by Raju M almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution: Affected version:

Description

Recently i migrated from windows to linux.
Getting below error in my production log while searching in projects.
And also, I am not able to update ticket with emoji symbol.
All other things are working fine.
Please help me how to resole the issue.

ActiveRecord::StatementInvalid (Mysql2::Error: Unknown column 'contacts.visibility' in 'where clause': SELECT DISTINCT `contacts`.`created_on`, `contacts`.`id` FROM `contacts` LEFT OUTER JOIN `contacts_projects` ON `contacts_projects`.`contact_id` = `contacts`.`id` LEFT OUTER JOIN `projects` ON `projects`.`id` = `contacts_projects`.`project_id` LEFT OUTER JOIN `addresses` ON `addresses`.`addressable_id` = `contacts`.`id` AND `addresses`.`address_type` = 'business' AND `addresses`.`addressable_type` = 'Contact' LEFT OUTER JOIN `notes` ON `notes`.`source_id` = `contacts`.`id` AND `notes`.`source_type` = 'Contact' WHERE ((projects.id <> -1 ) AND ((contacts.visibility = 1) OR ((1=0)) )) AND (((contacts.first_name LIKE '%asd%') OR (contacts.middle_name LIKE '%asd%') OR (contacts.last_name LIKE '%asd%') OR (contacts.company LIKE '%asd%') OR (contacts.email LIKE '%asd%') OR (addresses.full_address LIKE '%asd%') OR (contacts.background LIKE '%asd%') OR (notes.content LIKE '%asd%'))) ORDER BY `contacts`.`created_on` DESC, `contacts`.`id` DESC):
lib/plugins/acts_as_searchable/lib/acts_as_searchable.rb:171:in `fetch_ranks_and_ids'
lib/plugins/acts_as_searchable/lib/acts_as_searchable.rb:91:in `search_result_ranks_and_ids'
lib/redmine/search.rb:127:in `block in load_result_ids'
lib/redmine/search.rb:125:in `each'
lib/redmine/search.rb:125:in `load_result_ids'
lib/redmine/search.rb:115:in `block in load_result_ids_from_cache'
lib/redmine/search.rb:114:in `load_result_ids_from_cache'
lib/redmine/search.rb:99:in `result_ids'
lib/redmine/search.rb:70:in `result_count'
app/controllers/search_controller.rb:75:in `index'
lib/redmine/sudo_mode.rb:63:in `sudo_mode'

History

#1 Updated by Marius BALTEANU almost 5 years ago

Table "contacts" is not from Redmine core. You should contact plugin author.

#2 Updated by Go MAEDA almost 5 years ago

  • Status changed from New to Closed

The problem was obviously caused by a plugin. Closing.

#3 Updated by Raju M almost 5 years ago

  • Status changed from Closed to Reopened

But i am Getting "Internal error" while searching with some text in projects screen.
And also, I am not able to update ticket with emoji symbol.

I installed only only CRM plugin. That contacts table might belongs to this. Anyway its not impoartant for me.

#4 Updated by Go MAEDA almost 5 years ago

  • Status changed from Reopened to Closed

You should contact the author of the plugin because the problem was caused by the plugin.

Also available in: Atom PDF