Patch #26503

Update nokogiri gem (~> 1.8.0)

Added by Go MAEDA 3 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Gems support
Target version:4.0.0

Description

Now we can update Nokogiri to 1.8.0 because Ruby 2.1 support has been dropped by #25538 and #23630.

Quotation from CHANGELOG of Nokogiri 1.8.0 :

This release ends support for Ruby 2.1 on Windows in the x86-mingw32 and x64-mingw32 platform gems (containing pre-compiled DLLs). Official support ended for Ruby 2.1 on 2017-04-01.

Index: Gemfile
===================================================================
--- Gemfile    (revision 16868)
+++ Gemfile    (working copy)
@@ -13,7 +13,7 @@
 gem "roadie", "~> 3.2.1" 
 gem "mimemagic" 

-gem "nokogiri", "~> 1.7.2" 
+gem "nokogiri", "~> 1.8.0" 
 gem "i18n", "~> 0.7.0" 

 # Request at least rails-html-sanitizer 1.0.3 because of security advisories

Related issues

Blocked by Redmine - Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now req... Closed

Associated revisions

Revision 16885
Added by Jean-Philippe Lang 3 months ago

Update nokogiri gem (~> 1.8.0) (#26503).

Patch by Go MAEDA.

History

#1 Updated by Jean-Philippe Lang 3 months ago

  • Target version set to 4.0.0

#2 Updated by Go MAEDA 3 months ago

  • Blocked by Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now required added

#3 Updated by Jean-Philippe Lang 3 months ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang

Committed, thanks.

Also available in: Atom PDF