Defect #26699

Anonymous user should have their icon

Added by Go MAEDA about 1 year ago. Updated 9 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:3.3.6
Resolution:Fixed Affected version:

Description

ApplicationHelper#avatar method returns blank string instead of img tag for the anonymous user. The behavior causes disordered layout in IssuesController#show page.

This patch adds an icon for the anonymous user and fixes the broken layout.

Before:
The author of the issue is the anonymous user. But in the upper left corner of the page, the assignee's icon is displayed as if it is the author's icon because the anonymous user does not have their avatar icon.

No icon is displayed in the journal which was made by the anonymous user.

After:
New anonymous icon is displayed.

before1@2x.png (12.5 KB) Go MAEDA, 2017-08-15 16:32

before2@2x.png (7.66 KB) Go MAEDA, 2017-08-15 16:32

after1@2x.png (13.3 KB) Go MAEDA, 2017-08-15 16:32

after2@2x.png (8.56 KB) Go MAEDA, 2017-08-15 16:32

anonymous.ai - Vector data of the icon (Adobe Illustrator CC 2017) (371 KB) Go MAEDA, 2017-08-15 17:15

0001-Add-avatar-for-anonymous-user.patch Magnifier - patch (3.91 KB) Go MAEDA, 2017-08-15 17:52


Related issues

Related to Redmine - Patch #25775: Show assignee's icon in addition to author's icon Closed
Related to Redmine - Defect #28204: Too large avatar breaks gantt when assignee is a group Closed
Related to Redmine - Defect #28208: Anonymous icon is wrongly displayed when assignee is a group Closed

Associated revisions

Revision 17150
Added by Jean-Philippe Lang 9 months ago

Anonymous user should have their icon (#26699).

Patch by Go MAEDA.

Revision 17151
Added by Jean-Philippe Lang 9 months ago

Merged r17150 to 3.4-stable (#26699).

Revision 17152
Added by Jean-Philippe Lang 9 months ago

Merged r17150 to 3.3-stable (#26699).

History

#1 Updated by Go MAEDA about 1 year ago

  • Related to Patch #25775: Show assignee's icon in addition to author's icon added

#2 Updated by Go MAEDA about 1 year ago

#3 Updated by Go MAEDA about 1 year ago

Updated tests.

#4 Updated by Go MAEDA about 1 year ago

  • File deleted (0001-Add-avatar-for-anonymous-user.patch)

#5 Updated by Go MAEDA about 1 year ago

  • Target version set to 3.4.3

I think it is problematic that an assignee's icon looks like an author's icon in Redmine 3.4 when the issue's author is an anonymous user.

I suggest including this fix in 3.4.3.

#6 Updated by Jean-Philippe Lang 11 months ago

  • Target version changed from 3.4.3 to 3.4.4

I think it would be better to use the default gravatar icon instead of using our own.
What do you think?

#7 Updated by Go MAEDA 11 months ago

Jean-Philippe Lang wrote:

I think it would be better to use the default gravatar icon instead of using our own.
What do you think?

I prefer to have a special icon for anonymous user. We cannot distinguish a regular user with no Gravatar icon and anonymous user if default Gravatar icon is used for anonymous users.

#8 Updated by Mischa The Evil 11 months ago

Go MAEDA wrote:

[...]

I prefer to have a special icon for anonymous user. We cannot distinguish a regular user with no Gravatar icon and anonymous user if default Gravatar icon is used for anonymous users.

I agree with Go MEADA on this. We should be able to distinguish between regular users without Gravatar and anonymous user(s).

#9 Updated by Jean-Philippe Lang 9 months ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Committed, thanks.

#10 Updated by Jean-Philippe Lang 9 months ago

  • Target version changed from 3.4.4 to 3.3.6

#11 Updated by Go MAEDA 7 months ago

  • Related to Defect #28204: Too large avatar breaks gantt when assignee is a group added

#12 Updated by Go MAEDA 7 months ago

  • Related to Defect #28208: Anonymous icon is wrongly displayed when assignee is a group added

Also available in: Atom PDF