Defect #28110

Don't allow reassigning reported hours to the project if issue is a required field for time logs

Added by Stephane Evr 4 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Time tracking
Target version:3.4.5
Resolution:Fixed Affected version:3.4.4

Description

The problem occurs in the latest Redmine version (3.4.2)

Settings:

- Create an issue
- Log time on it
- Delete the issue

The following pops out:

There, we can apply, violating the "required issue" constraint.

settings.PNG (7.83 KB) Stephane Evr, 2018-01-31 11:00

reassign_dialog.png (9.87 KB) Stephane Evr, 2018-01-31 11:02

do_not_allow_nullify_time_entries_when_issue_is_required_for_time_entries.patch Magnifier (4.75 KB) Marius BALTEANU, 2018-01-31 22:56

do_not_allow_nullify_time_entries_when_issue_is_required_for_time_entries-v2.patch Magnifier (4.73 KB) Go MAEDA, 2018-02-11 07:01


Related issues

Related to Redmine - Feature #24577: Settings to make the issue and/or comment fields mandator... Closed

Associated revisions

Revision 17199
Added by Go MAEDA 3 months ago

Don't allow reassigning reported hours to the project if issue is a required field for time logs (#28110).

Patch by Marius BALTEANU.

Revision 17200
Added by Go MAEDA 3 months ago

Merged r17199 from trunk to 3.4-stable (#28110).

History

#1 Updated by Marius BALTEANU 4 months ago

Stephane, thanks for pointing this out.

Attached is a patch that fixes this issue. Also, it hides the option "Assign reported hours to the project" when the issue is required for time entries.

#2 Updated by Go MAEDA 4 months ago

  • Related to Feature #24577: Settings to make the issue and/or comment fields mandatory for time logs added

#3 Updated by Go MAEDA 4 months ago

Marius, thank you for writing the patch. But I slightly modified because the patch cannot be cleanly applied to the current trunk.

I tested the patch and it works fine, setting target version to 3.4.5.

#4 Updated by Go MAEDA 3 months ago

  • Subject changed from Time Entries of an issue pending deletion can be reassigned to the project itself even if issue is a required field to Don't allow reassigning reported hours to the project if issue is a required field for time logs
  • Category set to Time tracking
  • Status changed from Confirmed to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed.
Thank you for reporting and fixing this issue.

Also available in: Atom PDF