Defect #28576

Attachments are added even if validation fails when updating an issue via email

Added by Doruk Fi┼ček 8 months ago. Updated 16 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Email receiving
Target version:3.3.9
Resolution:Fixed Affected version:

Description

Setting: There's an issue that a required field's empty.

When I try to update the issue via e-mail (but not add value to the required field), Redmine rejects the e-mail update (as it should).

However if the e-mail has an attachment, it adds the attachment to the issue nevertheless.

What it should do is to reject the attachment also.

28576.patch Magnifier (1.51 KB) Takenori TAKAKI, 2018-10-04 04:03

Associated revisions

Revision 17630
Added by Go MAEDA 17 days ago

Fix: Attachments are added even if validation fails when updating an issue via email (#28576).

Patch by Takenori TAKAKI.

Revision 17631
Added by Go MAEDA 16 days ago

Merged r17630 from trunk to 3.4-stable (#28576).

Revision 17632
Added by Go MAEDA 16 days ago

Merged r17630 from trunk to 3.3-stable (#28576).

History

#1 Updated by Go MAEDA 2 months ago

  • Category set to Email receiving

#2 Updated by Takenori TAKAKI 2 months ago

I found the cause of this problem in MailHandler#receive_issue_reply.
I made a patch and attach it.

#3 Updated by Go MAEDA 2 months ago

  • Target version set to 3.3.9

Setting the target version to 3.3.9.

#4 Updated by Go MAEDA 17 days ago

  • Subject changed from Redmine rejects e-mail but adds the attachment to Attachments are added even if validation fails when updating an issue via email
  • Status changed from New to Resolved
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you all for reporting and fixing the issue.

#5 Updated by Go MAEDA 16 days ago

  • Status changed from Resolved to Closed

Merged to stable branches.

Also available in: Atom PDF