Defect #28774

Internal Error when Submit the Description with Vietnamese in Unicode fonts

Added by De Dang about 2 years ago. Updated 11 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:3.4.5

Description

Hi Team,

I am evaluating redmine features and when i submit an issue with Vietnamese unicode fonts in Description text area of the issue. I got the error on browser:
"
Internal error
"
in Redmine Log, I got this error message:
"
rdmine Mysql2::Error: Incorrect string value
"

Could you please advise me how to resolve the problem on my test server.

Thanks,
De


Related issues

Related to Redmine - Feature #31921: Changes to properly support 4 byte characters (emoji) whe... Closed

History

#1 Updated by De Dang about 2 years ago

This error just happens when Update 1 issue. Creating a new issue with description in vietnamese is no problem.

#2 Updated by De Dang about 2 years ago

  • Status changed from New to Resolved

I converted redmine tables to utf8mb4. The problem is resolved.

#3 Updated by Marius BALTEANU 11 months ago

  • Related to Feature #31921: Changes to properly support 4 byte characters (emoji) when database is MySQL added

#4 Updated by Marius BALTEANU 11 months ago

  • Status changed from Resolved to Closed
  • Priority changed from High to Normal
  • Resolution set to Duplicate

#5 Updated by Marius BALTEANU 11 months ago

  • Resolution changed from Duplicate to Fixed

Also available in: Atom PDF