Feature #2905

Enable per-tracker issue status set

Added by Haomin Liu about 10 years ago. Updated almost 3 years ago.

Status:ClosedStart date:2009-03-05
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

Hi All,

We are trying to use redmine to track not only development work items, but also general work items.

This brings a problem. For different types of work items, they seems to have different sets of issue stauts.

For e.g.,
1. For feature dev. items may have such set of status, say:
"proposed", "in evaluation", "in processing", "resolved", "verified"

2. For service related issues, it may have brand new set of status,
"New", "escalate to R&D", "resolved by customer service", "resolved by R&D", "Invalid"

Now Redmine seems to have only one set of status definition, I took some time but can not figure out how to configure it to fit my current need.

Any solution to me is appreciated!

Best Wishes
Haomin Liu
Brion Technologies.


Related issues

Related to Redmine - Feature #1853: Make Projects truly independent of each other New 2008-09-04
Related to Redmine - Feature #973: Assign different status sets and workflows for separate p... New 2008-04-02
Related to Redmine - Feature #7839: Limit trackers for new issue to certain roles Closed 2011-03-11
Duplicates Redmine - Feature #5816: New issue initial status should be settable in workflow Closed 2010-07-05

History

#1 Updated by Thomas Pihl about 10 years ago

Dup of #973

#2 Updated by Danil Sotnikov about 9 years ago

+1
I also hope that will be supported :

custom fields appear only if the field A has the value B

#3 Updated by Krzysztof Szalast about 9 years ago

+1
I also need that feature

#4 Updated by Wytze Keuning about 9 years ago

Maybe I don't fully understand what it is that you want; but doesn't Redmine already support this feature? You can add different Issue statuses; you can also link these statuses to trackers and define a workflow. Depending on the tracker you choose when creating an issue you see different statuses listed (as defined in your workflow).

#5 Updated by Dipan Mehta about 6 years ago

As of today - Redmine 2.2.x this is quite possible already without any extra code. Basically, you can define all of the states as statuses

"proposed", "in evaluation", "in processing", "resolved", "verified"
as well as
"New", "escalate to R&D", "resolved by customer service", "resolved by R&D", "Invalid"

Now (under Administration > Workflow) for tracker feature do not tick for any state transition which goes to any other the states meant for service types. That's it, you will never see any of the "resolved by service" etc. under a feature!

This feature should be closed.

#6 Updated by Toshi MARUYAMA over 5 years ago

  • Related to Feature #7839: Limit trackers for new issue to certain roles added

#7 Updated by Marius BALTEANU almost 3 years ago

I think that this feature is available in Redmine 3.2.0 (#5816)

#8 Updated by Toshi MARUYAMA almost 3 years ago

  • Category deleted (Custom fields)
  • Assignee deleted (Jean-Philippe Lang)
  • Priority changed from High to Normal

#9 Updated by Toshi MARUYAMA almost 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Marius BALTEANU wrote:

I think that this feature is available in Redmine 3.2.0 (#5816)

Thank you for your pointing out.

#10 Updated by Toshi MARUYAMA almost 3 years ago

  • Duplicates Feature #5816: New issue initial status should be settable in workflow added

#11 Updated by Toshi MARUYAMA almost 3 years ago

Danil Sotnikov wrote:

+1
I also hope that will be supported :

custom fields appear only if the field A has the value B

Duplicate of #22026 or etc.

Also available in: Atom PDF