Feature #31128

Drop Ruby < 2.5 support

Added by Marius BALTEANU 4 months ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Ruby support
Target version:Unplanned backlogs
Resolution:

Description

Rails 6 requires at least Ruby 2.5.0

root@85be5e8d7c3e:/work# bundle update
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "ruby":
  In Gemfile:
    ruby

    rails (= 6.0.0.beta3) was resolved to 6.0.0.beta3, which depends on
      ruby (>= 2.5.0)

Related issues

Related to Redmine - Feature #29914: Migrate to Rails 6 New

History

#1 Updated by Marius BALTEANU 4 months ago

#2 Updated by Marius BALTEANU 4 months ago

#3 Updated by Marius BALTEANU 4 months ago

Also available in: Atom PDF