Patch #32444

Add missing fixture to Redmine::WikiFormatting::MacrosTest

Added by Yuichi HARADA 3 months ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Code cleanup/refactoring
Target version:-

Description

Redmine::WikiFormatting::MacrosTest#test_issue_macro_should_render_link_to_issue has failed.

$ RAILS_ENV=test bundle exec rake db:migrate:reset

$ RAILS_ENV=test bundle exec rake test TEST=test/unit/lib/redmine/wiki_formatting/macros_test.rb
Run options: --seed 63852

# Running:

....................F

Failure:
Redmine::WikiFormatting::MacrosTest#test_issue_macro_should_render_link_to_issue [test/unit/lib/redmine/wiki_formatting/macros_test.rb:414]:
--- expected
+++ actual
@@ -1 +1 @@
-"<p><a class=\"issue tracker-1 status-1 priority-4 priority-lowest\" href=\"/issues/1\">Bug #1</a>: Cannot print recipes</p>" 
+"<p><a class=\"issue tracker-1 status-1 \" href=\"/issues/1\">Bug #1</a>: Cannot print recipes</p>" 

bin/rails test test/unit/lib/redmine/wiki_formatting/macros_test.rb:412

........................

Finished in 1.200809s, 37.4747 runs/s, 60.7923 assertions/s.
45 runs, 73 assertions, 1 failures, 0 errors, 0 skips

I think that because the fixtures not enough.

diff --git a/test/unit/lib/redmine/wiki_formatting/macros_test.rb b/test/unit/lib/redmine/wiki_formatting/macros_test.rb
index 208c0157a..ceda727c8 100644
--- a/test/unit/lib/redmine/wiki_formatting/macros_test.rb
+++ b/test/unit/lib/redmine/wiki_formatting/macros_test.rb
@@ -33,7 +33,7 @@ class Redmine::WikiFormatting::MacrosTest < Redmine::HelperTest
            :versions, :documents,
            :wikis, :wiki_pages, :wiki_contents,
            :boards, :messages,
-           :attachments
+           :attachments, :enumerations

   def setup
     super

Associated revisions

Revision 19071
Added by Go MAEDA 2 months ago

Add missing fixture to Redmine::WikiFormatting::MacrosTest (#32444).

Patch by Yuichi HARADA.

Revision 19329
Added by Go MAEDA about 1 month ago

Merged r19071 from trunk to 4.1-stable (#32444, #29489).

History

#1 Updated by Go MAEDA 2 months ago

  • Target version set to 4.2.0

Confirmed. Setting the target version to 4.2.0.

#2 Updated by Go MAEDA 2 months ago

  • Subject changed from Add missing fixtures to Redmine::WikiFormatting::MacrosTest to Add missing fixture to Redmine::WikiFormatting::MacrosTest
  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thank you.

#3 Updated by Yuichi HARADA 2 months ago

  • Copied to Patch #32478: Add missing fixture to TimelogControllerTest added

#4 Updated by Go MAEDA 2 months ago

  • Copied to deleted (Patch #32478: Add missing fixture to TimelogControllerTest)

#5 Updated by Go MAEDA about 1 month ago

  • Target version deleted (4.2.0)

Cleared the target version because the fix is a part of #29489.

Also available in: Atom PDF