Defect #32859

Issue list: long text custom field missing in PDF export

Added by Ed Baker 6 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:PDF export
Target version:4.1.1
Resolution:Fixed Affected version:4.1.0

Description

The new "long text" custom field in the issue list (a new feature that is highly appreciated!) can be selected and displayed on the HTML issue (same as i.e. "Description" or "Last notes") via the checkboxes under "Options" as usual. But on PDF export the description and last notes are exported, but not the custom field(s).

(tested with a bitnami VM image, Redmine V4.1.0, Ruby 2.5.7-p206, Rails 5.2.4.1)

fix_32859.patch Magnifier (2.3 KB) Marius BALTEANU, 2020-01-25 11:19


Related issues

Related to Redmine - Feature #26081: Allow full_width_layout long-text custom fields to appear... Closed

Associated revisions

Revision 19464
Added by Go MAEDA 6 months ago

Issue list: long text custom field missing in PDF export (#32859).

Patch by Marius BALTEANU.

Revision 19465
Added by Go MAEDA 6 months ago

Merged r19464 from trunk to 4.1-stable (#32859).

Patch by Marius BALTEANU.

History

#1 Updated by Marius BALTEANU 6 months ago

  • Status changed from New to Confirmed
  • Assignee set to Marius BALTEANU
  • Target version set to 4.1.1

#2 Updated by Marius BALTEANU 6 months ago

  • Related to Feature #26081: Allow full_width_layout long-text custom fields to appear in the issue list like 'Description' (as a block column) added

#3 Updated by Marius BALTEANU 6 months ago

  • File fix_32765.patch added
  • Subject changed from issue list: long text custom field missing in PDF export to Issue list: long text custom field missing in PDF export
  • Assignee deleted (Marius BALTEANU)

Attached is the fix. I used the same logic from issue list to display the block columns instead of hardcoding each column, but with only difference: column label is always shown because the user that receives the PDF doesn't know which column was added to the export.

@Ed Baker, thanks for reporting the patch, the fix will be available in version 4.1.1.

#4 Updated by Marius BALTEANU 6 months ago

  • File deleted (fix_32765.patch)

#5 Updated by Marius BALTEANU 6 months ago

#6 Updated by Go MAEDA 6 months ago

  • Status changed from Confirmed to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you.

#7 Updated by Ed Baker 5 months ago

JFTR: applied the patch and works perfectly, Thanks!

Also available in: Atom PDF