Defect #33082

Links in the last column in gantt are unclickable

Added by Jaebok Oh about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Gantt
Target version:4.1.1
Resolution:Fixed Affected version:4.1.0

Description

The link does not work.

ganttchart.png (49.2 KB) Jaebok Oh, 2020-03-03 08:28


Related issues

Related to Redmine - Feature #27672: Show selected columns in gantt chart Closed

Associated revisions

Revision 19555
Added by Go MAEDA about 1 month ago

Links in the last column in gantt are unclickable (#33082).

Patch by Mizuki ISHIKAWA.

Revision 19556
Added by Go MAEDA about 1 month ago

Merged r19555 from trunk to 4.1-stable (#33082).

History

#1 Updated by Jaebok Oh about 1 month ago

#2 Updated by Jaebok Oh about 1 month ago

The link does not seem to work only if it is an entry in the last field.

#3 Updated by Go MAEDA about 1 month ago

  • Subject changed from Attachments are not downloaded. to Cannot download attached files in gantt when "Files" column is the last column
  • Status changed from New to Confirmed

#4 Updated by Go MAEDA about 1 month ago

  • Related to Feature #27672: Show selected columns in gantt chart added

#5 Updated by Mizuki ISHIKAWA about 1 month ago

The links are displayed behind other elements due to the z-index style.
I think that it can be fixed by rewriting as follows.

diff --git a/public/stylesheets/application.css b/public/stylesheets/application.css
index b3b4d9b42..131da3213 100644
--- a/public/stylesheets/application.css
+++ b/public/stylesheets/application.css
@@ -1319,9 +1319,9 @@ table.gantt-table td {
 }
 .gantt_subjects_container:not(.draw_selected_columns) .gantt_hdr,
 .last_gantt_selected_column .gantt_hdr {
-  z-index: 10;
   border-right: 1px solid #c0c0c0;
 }
+.last_gantt_selected_column .gantt_selected_column_container,
 .gantt_subjects_container .gantt_subjects * {
   z-index: 10;
 }

#6 Updated by Go MAEDA about 1 month ago

  • Subject changed from Cannot download attached files in gantt when "Files" column is the last column to Links in the last column in gantt are unclickable
  • Target version set to 4.1.1

Setting the target version to 4.1.1.

#7 Updated by Go MAEDA about 1 month ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the fix. Thank you.

#8 Updated by Go MAEDA about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF