Defect #34032

Project settings tab contains two items with the same id

Added by Ali Hamdan about 1 year ago. Updated 8 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Project settings
Target version:4.2.0
Resolution:Fixed Affected version:

Description

In the project setting tabs the [DOM] have 2 elements with non-unique id #edit_project_1 which are in the _edit.html.erb and _issues.html.erb tab which both of them contains labelled_form_for @project.
In order to fix it i added

labelled_form_for @project ,:as => "project_issues_tracker" 

in the _issues tab.

project-tab-id.png (60.6 KB) Go MAEDA, 2020-09-25 02:30

issue-tracking-tab-id.png (55 KB) Go MAEDA, 2020-09-25 02:30

35029fd5ea9ad41ab80f0d9987791c64d4f082fb.patch Magnifier (793 Bytes) Marius BALTEANU, 2021-02-28 18:19


Related issues

Related to Redmine - Defect #34982: Cannot change the default version and default assignee un... Closed

Associated revisions

Revision 20766
Added by Go MAEDA 8 months ago

Project settings tab contains two items with the same id (#34032).

Patch by Ali Hamdan and Marius BALTEANU.

History

#1 Updated by Go MAEDA about 1 year ago

Confirmed the issue.

#2 Updated by Go MAEDA 8 months ago

  • Tracker changed from Patch to Defect
  • Status changed from New to Confirmed

#3 Updated by Go MAEDA 8 months ago

  • Category changed from Projects to Project settings

#4 Updated by Marius BALTEANU 8 months ago

The change looks good, but I propose to use project_issue_tracking because the form handles settings related to Issue tracking module (attached a patch).

The tests pass: https://gitlab.com/redmine-org/redmine/-/pipelines/263093258

#5 Updated by Go MAEDA 8 months ago

  • Target version changed from Candidate for next minor release to 4.1.2

Setting the target version to 4.1.2.

#6 Updated by Go MAEDA 8 months ago

  • Subject changed from Project Settings Tabs contains 2 element same id to Project settings tab contains two items with the same id
  • Status changed from Confirmed to Resolved
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you.

#7 Updated by Go MAEDA 8 months ago

  • Status changed from Resolved to Closed
  • Target version changed from 4.1.2 to 4.2.0

#8 Updated by Marius BALTEANU 7 months ago

  • Related to Defect #34982: Cannot change the default version and default assignee under settings added

Also available in: Atom PDF