Feature #3431

Notify users if openid gem isn't installed

Added by Peter Baumgartner about 11 years ago. Updated about 11 years ago.

Status:ClosedStart date:2009-05-29
Priority:NormalDue date:
Assignee:Eric Davis% Done:

100%

Category:Documentation
Target version:-
Resolution:Fixed

Description

Administration > Settings > Authentication > Allow OpenID login and registration is disabled if the ruby-openid gem isn't installed.

There should be some sort of notification or documentation that the gem is required.

History

#1 Updated by Mischa The Evil about 11 years ago

Peter Baumgartner wrote:

There should be some sort of notification or documentation that the gem is required.

I've at least added some documentation about it here and here.

@Eric:

Do we (still) need this as a notification inside Redmine settings-view also (as a description or so)?

Regards,

Mischa.

#2 Updated by Jean-Philippe Lang about 11 years ago

  • Tracker changed from Defect to Feature

#3 Updated by Eric Davis about 11 years ago

  • % Done changed from 0 to 100

Mischa The Evil wrote:

I've at least added some documentation about it here and here.

Mischa, that will work. One problem I heard about in IRC a few times was that some systems have an older ruby-openid gem installed, which isn't compatible. I've updated the wiki page to say version 2 is required.

#4 Updated by Eric Davis about 11 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

(Missed the close status on the last comment)

Also available in: Atom PDF