Defect #34580

Custom field labels do not contain class "error" when the field value is invalid

Added by Marius BALTEANU 14 days ago. Updated 12 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:4.2.0
Resolution:Fixed Affected version:

Description

When the form contains invalid field values, the class "error" is added only to standard fields. We should add it also to custom fields in order to be able to highlight those fields (#32764).

The attached patch fixes this.

0001-Add-class-error-to-custom-fields-with-validation-err.patch Magnifier (3.1 KB) Marius BALTEANU, 2021-01-09 20:36


Related issues

Related to Redmine - Feature #32764: Make form validation errors more obvious for users Closed

Associated revisions

Revision 20710
Added by Go MAEDA 12 days ago

Add class 'error' to custom fields with validation errors (#32764, #34580).

Patch by Marius BALTEANU.

History

#2 Updated by Marius BALTEANU 14 days ago

  • Subject changed from Custom field labels doesn't contain class "error" when the field value is invalid to Custom field labels do not contain class "error" when the field value is invalid

#3 Updated by Go MAEDA 14 days ago

  • Related to Feature #32764: Make form validation errors more obvious for users added

#4 Updated by Go MAEDA 14 days ago

  • Status changed from New to Confirmed

#5 Updated by Go MAEDA 12 days ago

  • Status changed from Confirmed to Closed
  • Target version deleted (Candidate for next major release)
  • Resolution set to Fixed

Committed as a part of #32764. Thank you.

#6 Updated by Marius BALTEANU 12 days ago

  • Target version set to 4.2.0

We should keep this in Changelog because there were some changes regarding how the validation messages are stored in the object.

Also available in: Atom PDF