Defect #35195

Long Text label name is not displayed

Added by ryou soda 7 months ago. Updated 7 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Marius BALTEANU% Done:

0%

Category:Custom fields
Target version:-
Resolution:Invalid Affected version:4.1.0

Description

When using a custom field of Long Text with "Full width layout", the label name is not displayed on the ticket screen if no value is entered.
The situation is the same for Redmine 4.1 / 4.2.

CF_SETTINGS.jpg (76.7 KB) ryou soda, 2021-05-02 03:31

noinput_long-text.jpg (121 KB) ryou soda, 2021-05-02 03:31

input_long-text.jpg (453 KB) ryou soda, 2021-05-02 03:31

long-text_not-wide.jpg (97 KB) ryou soda, 2021-05-03 12:55


Related issues

Related to Redmine - Patch #21705: Option for long text custom fields to be displayed using ... Closed

History

#1 Updated by ryou soda 7 months ago

Label name "Long-Text (Wide)" is not displayed

#2 Updated by Marius BALTEANU 7 months ago

  • Status changed from New to Closed
  • Resolution set to Invalid

This is the expected behaviour, custom fields with empty value are not rendered regardless their type (long text or not). Please reopen if you consider this a feature request, but in my opinion, displaying all the custom fields by default will eat a lot of space without any benefit.

#3 Updated by ryou soda 7 months ago

I understand the policy of not issuing it if it is empty.
If so, is it an unintended behavior that is displayed when it is not "Full width layout"?

#4 Updated by Marius BALTEANU 7 months ago

  • Status changed from Closed to Reopened
  • Assignee set to Marius BALTEANU

#5 Updated by Marius BALTEANU 7 months ago

  • Resolution deleted (Invalid)

Sorry, I posted a misinformation in my previous note.

I checked again now and all custom fields are shown in issue detail page except full width custom fields which are not rendered when the value is blank. You can see r16257 from #21705 for more details.

Considering this new and correct information, do you want to keep this open and track it as a feature request?

#6 Updated by Marius BALTEANU 7 months ago

  • Related to Patch #21705: Option for long text custom fields to be displayed using full width added

#7 Updated by ryou soda 7 months ago

I understand that the label will be hidden only in the case of "Full width layout", so it is OK to close it.

#8 Updated by Marius BALTEANU 7 months ago

  • Status changed from Reopened to Closed
  • Resolution set to Invalid

Thanks for your feedback.

Also available in: Atom PDF