Defect #35916

Time-Entries CSV export is broken

Added by der gl0wn about 1 year ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Wont fix Affected version:

Description

If you want to export certain rows in the time-entries, all columns are exported anyway.

How reproducible:

1. open time entries
2. select specific rows
3. retrieve via CSV

csv_export.png (162 KB) Karel Pičman, 2022-08-30 07:42

History

#1 Updated by Go MAEDA 12 months ago

  • Category set to Time tracking

I cannot reproduce the issue. What version of Redmine are you using?

#2 Updated by der gl0wn 12 months ago

Go MAEDA wrote:

I cannot reproduce the issue. What version of Redmine are you using?

Were currently on 4.2.1.

#3 Updated by Karel Pičman about 1 month ago

Here is an evidence from Redmine 5.0.0.stable.21546. However, it seems to be a feature, that CSV export ignores any line selection and exports all lines instead.

#4 Updated by Go MAEDA about 1 month ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

The CSV export feature is supposed to export all entries selected by the filter. And the checkboxes are for selecting the target for bulk edit, not for CSV export.

Also available in: Atom PDF