Project

General

Profile

Actions

Defect #37251

closed

openssl_verify_mode not honored/not working anymore

Added by Bernhard Maehr about 2 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Email notifications
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

Hello,

After the upgrade of Redmine to 5.0.1 (and upgrade of Ruby and Passenger) the setting openssl_verify_mode: 'NONE' is not working anymore.
Tried also 'none' and 'OpenSSL::SSL::VERIFY_NONE'.

The solution from https://www.redmineup.com/pages/help/helpdesk/how-to-fix-issues-with-ssl-certificate (Error 1) solved the problem for me.


Related issues

Is duplicate of Redmine - Defect #37753: Cannot send mail through smtp due to TLS errorsClosedMarius BĂLTEANU

Actions
Actions #1

Updated by Go MAEDA about 2 years ago

Could you explain in detail which feature of Redmine is affected by openssl_verify_mode and what kind of problem you are experiencing?

Actions #2

Updated by Holger Just about 2 years ago

  • Status changed from New to Needs feedback
Actions #3

Updated by Bernhard Maehr about 2 years ago

Documentition: https://www.redmine.org/projects/redmine/wiki/emailconfiguration#Troubleshooting

The error message when sending email is "unable to get local issuer certificate"

Actions #4

Updated by Holger Just about 2 years ago

Please show your entire configuration.yml file (leave out / replace any usernames or passwords, but strictly keep the whole structure as is). Also, please show the full error you get, including its stack trace.

Actions #5

Updated by Marius BĂLTEANU 5 months ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

I think is the same issue reported in #37753 which was fixed in recent Redmine versions (5.1+). Please reopen if I'm wrong with the details requested by Holger.

Actions #6

Updated by Marius BĂLTEANU 5 months ago

  • Is duplicate of Defect #37753: Cannot send mail through smtp due to TLS errors added
Actions

Also available in: Atom PDF